aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch/openvswitch_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-networking/openvswitch/openvswitch_git.bb')
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb42
1 files changed, 16 insertions, 26 deletions
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index fa1ec4dc..b7d9b8dd 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -4,7 +4,7 @@ DEPENDS += "virtual/kernel"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-RDEPENDS_${PN}-ptest += "\
+RDEPENDS:${PN}-ptest += "\
python3-logging python3-syslog python3-io python3-core \
python3-fcntl python3-shell python3-xml python3-math \
python3-datetime python3-netclient python3 sed \
@@ -14,32 +14,25 @@ RDEPENDS_${PN}-ptest += "\
"
S = "${WORKDIR}/git"
-PV = "2.13+${SRCPV}"
-
-FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:"
-
-SRCREV = "71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3"
-SRC_URI = "file://openvswitch-switch \
- file://openvswitch-switch-setup \
- file://openvswitch-testcontroller \
- file://openvswitch-testcontroller-setup \
- git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.13 \
- file://openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch \
- file://run-ptest \
- file://disable_m4_check.patch \
- file://kernel_module.patch \
- file://python-switch-remaining-scripts-to-use-python3.patch \
- file://systemd-update-tool-paths.patch \
- file://systemd-create-runtime-dirs.patch \
- file://0001-ovs-use-run-instead-of-var-run-for-in-systemd-units.patch \
+PV = "3.3.0"
+CVE_VERSION = "3.3.0"
+
+FILESEXTRAPATHS:append := "${THISDIR}/${PN}-git:"
+
+SRCREV = "1c1f173ce8a8534e262083bc4db3ee15f05231c0"
+SRC_URI += "git://github.com/openvswitch/ovs.git;protocol=https;branch=branch-3.3 \
+ file://openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch \
+ file://run-ptest \
+ file://disable_m4_check.patch \
+ file://systemd-update-tool-paths.patch \
+ file://systemd-create-runtime-dirs.patch \
+ file://Makefile.am-set-the-python3-interpreter-with-usr-bin.patch \
"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
-DPDK_INSTALL_DIR ?= "/opt/dpdk"
-
PACKAGECONFIG ?= "libcap-ng"
-PACKAGECONFIG[dpdk] = "--with-dpdk=${STAGING_DIR_TARGET}${DPDK_INSTALL_DIR}/share/${TARGET_ARCH}-native-linuxapp-gcc,,dpdk,dpdk"
+PACKAGECONFIG[dpdk] = "--with-dpdk=shared,,dpdk,dpdk"
PACKAGECONFIG[libcap-ng] = "--enable-libcapng,--disable-libcapng,libcap-ng,"
PACKAGECONFIG[ssl] = ",--disable-ssl,openssl,"
@@ -49,7 +42,7 @@ PACKAGECONFIG[ssl] = ",--disable-ssl,openssl,"
# EXTRA_OECONF += "--with-linux=${STAGING_KERNEL_BUILDDIR} --with-linux-source=${STAGING_KERNEL_DIR} KARCH=${TARGET_ARCH}"
# silence a warning
-FILES_${PN} += "/lib/modules"
+FILES:${PN} += "/lib/modules"
inherit ptest
@@ -59,6 +52,3 @@ do_install_ptest() {
oe_runmake test-install
}
-do_install_append() {
- oe_runmake modules_install INSTALL_MOD_PATH=${D}
-}