aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/yocto-cfg-fragments.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/yocto-cfg-fragments.bb')
-rw-r--r--recipes-kernel/linux/yocto-cfg-fragments.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-kernel/linux/yocto-cfg-fragments.bb b/recipes-kernel/linux/yocto-cfg-fragments.bb
new file mode 100644
index 00000000..e6815715
--- /dev/null
+++ b/recipes-kernel/linux/yocto-cfg-fragments.bb
@@ -0,0 +1,37 @@
+HOMEPAGE = "https://git.yoctoproject.org/cgit/cgit.cgi/yocto-kernel-cache/"
+SUMMARY = "Kernel configuration fragments"
+DESCRIPTION = "Typically used as part of a kernel clone, this is the standalone \
+fragment repository. Making it available to other fragment management schemes \
+"
+SECTION = "devel"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+INHIBIT_DEFAULT_DEPS = "1"
+
+LINUX_VERSION ?= "6.6"
+PV = "v${LINUX_VERSION}+git${SRCREV}"
+
+SRCREV = "eb283ea577df80542d48f0c498365960b4c4ecd9"
+SRC_URI = "\
+ git://git.yoctoproject.org/yocto-kernel-cache;branch=yocto-${LINUX_VERSION} \
+ "
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${base_prefix}/kcfg
+
+ # copy the configuration fragments over to the native deploy
+ cp -r ${S}/* ${D}${base_prefix}/kcfg
+ # scripts bring in a bash dependency we don't want
+ rm -rf ${D}${base_prefix}/kcfg/scripts
+}
+
+FILES:${PN} += "kcfg/"
+SYSROOT_DIRS += "${base_prefix}/kcfg"
+BBCLASSEXTEND = "native nativesdk"
+