aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/xvisor/xvisor_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/xvisor/xvisor_git.bb')
-rw-r--r--recipes-extended/xvisor/xvisor_git.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/recipes-extended/xvisor/xvisor_git.bb b/recipes-extended/xvisor/xvisor_git.bb
index 831c943b..205951e9 100644
--- a/recipes-extended/xvisor/xvisor_git.bb
+++ b/recipes-extended/xvisor/xvisor_git.bb
@@ -1,6 +1,6 @@
SUMMARY = "Xvisor is an open-source type-1 hypervisor, which aims at providing a monolithic, light-weight, portable, and flexible virtualization solution."
DESCRIPTION = "Xvisor primarily supports Full virtualization hence, supports a wide range of unmodified guest operating systems. Paravirtualization is optional for Xvisor and will be supported in an architecture independent manner (such as VirtIO PCI/MMIO devices) to ensure no-change in guest OS for using paravirtualization."
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS += "dtc-native dosfstools-native mtools-native"
@@ -8,11 +8,13 @@ require xvisor-configs.inc
inherit autotools-brokensep
+PV = "0.3.0+git"
+
# This version support the RISC-V v0.5.0 Hypervisor extensions
-SRCREV = "b3dac5b1f61f23f21dc59b3880897cff78f3b618"
-SRC_URI = "git://github.com/avpatel/xvisor-next.git \
+SRCREV = "6b23764a1439f9d08b2ed2f363da522460d8a22b"
+SRC_URI = "git://github.com/avpatel/xvisor-next.git;branch=master;protocol=https \
file://0001-TESTS-Don-t-specify-mabi-or-march-for-RISC-V.patch \
- file://0001-EMULATORS-Allow-Xvisor-to-compile-with-gcc-10.patch \
+ file://0001-build-use-usr-bin-env-for-python-scripts.patch \
"
S = "${WORKDIR}/git"
@@ -25,7 +27,7 @@ do_configure() {
oe_runmake ${CONFIG}
}
-do_install_append() {
+do_install:append() {
install -d ${D}
install -m 755 ${B}/build/vmm.* ${D}/
@@ -44,12 +46,12 @@ do_deploy () {
addtask deploy after do_install
-FILES_${PN} += "/vmm.*"
-FILES_${PN} += "/*.dtb"
+FILES:${PN} += "/vmm.*"
+FILES:${PN} += "/*.dtb"
COMPATIBLE_HOST = "(aarch64|riscv64|riscv32).*"
INHIBIT_PACKAGE_STRIP = "1"
# ERROR: xvisor-git-r0 do_package_qa: QA Issue: File /vmm.elf in package xvisor doesn't have GNU_HASH (didn't pass LDFLAGS?) [ldflags]
# ERROR: xvisor-git-r0 do_package_qa: QA Issue: xvisor: ELF binary /vmm.elf has relocations in .text [textrel]
-INSANE_SKIP_${PN} += "ldflags textrel"
+INSANE_SKIP:${PN} += "ldflags textrel"