aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/ipxe/files/build-be-explicit-about-fcommon-compiler-directive.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/ipxe/files/build-be-explicit-about-fcommon-compiler-directive.patch')
-rw-r--r--recipes-extended/ipxe/files/build-be-explicit-about-fcommon-compiler-directive.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-extended/ipxe/files/build-be-explicit-about-fcommon-compiler-directive.patch b/recipes-extended/ipxe/files/build-be-explicit-about-fcommon-compiler-directive.patch
new file mode 100644
index 00000000..d4a2c732
--- /dev/null
+++ b/recipes-extended/ipxe/files/build-be-explicit-about-fcommon-compiler-directive.patch
@@ -0,0 +1,33 @@
+From f982a712979619dbae2c6e0d741757e2ce94be11 Mon Sep 17 00:00:00 2001
+Message-Id: <f982a712979619dbae2c6e0d741757e2ce94be11.1602165412.git.bertrand.marquis@arm.com>
+From: Bruce Rogers <brogers@suse.com>
+Date: Wed, 6 May 2020 15:03:02 -0600
+Subject: [PATCH] [build] Be explicit about -fcommon compiler directive
+
+gcc10 switched default behavior from -fcommon to -fno-common. Since
+"__shared" relies on the legacy behavior, explicitly specify it.
+
+Upstream-Status: Backport
+
+Signed-off-by: Bruce Rogers <brogers@suse.com>
+Modified-by: Michael Brown <mcb30@ipxe.org>
+Signed-off-by: Michael Brown <mcb30@ipxe.org>
+---
+ src/Makefile.housekeeping | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/Makefile.housekeeping b/src/Makefile.housekeeping
+index 66d6dd44..b6c61c11 100644
+--- a/Makefile.housekeeping
++++ b/Makefile.housekeeping
+@@ -418,6 +418,7 @@ CFLAGS += -Os
+ CFLAGS += -g
+ ifeq ($(CCTYPE),gcc)
+ CFLAGS += -ffreestanding
++CFLAGS += -fcommon
+ CFLAGS += -Wall -W -Wformat-nonliteral
+ HOST_CFLAGS += -Wall -W -Wformat-nonliteral
+ endif
+--
+2.17.1
+