aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/images/xvisor-image-minimal.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/images/xvisor-image-minimal.bb')
-rw-r--r--recipes-extended/images/xvisor-image-minimal.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-extended/images/xvisor-image-minimal.bb b/recipes-extended/images/xvisor-image-minimal.bb
new file mode 100644
index 00000000..7c23de5b
--- /dev/null
+++ b/recipes-extended/images/xvisor-image-minimal.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "A minimal Xvisor image"
+
+INITRD_IMAGE = "core-image-minimal-initramfs"
+
+IMAGE_INSTALL += " \
+ packagegroup-core-boot \
+ packagegroup-core-ssh-openssh \
+ "
+
+# The hypervisor may not be within the dom0 filesystem image but at least
+# ensure that it is deployable:
+do_build[depends] += "xvisor:do_deploy"
+
+LICENSE = "MIT"
+
+inherit core-image
+
+# Enable runqemu. eg: runqemu xvisor-image-minimal nographic slirp
+QB_DEFAULT_KERNEL = "vmm.bin"
+QB_OPT_APPEND:append:riscv64 = " -cpu rv64,x-h=true "