aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/go/go-fsnotify_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/go/go-fsnotify_git.bb')
-rw-r--r--recipes-devtools/go/go-fsnotify_git.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/recipes-devtools/go/go-fsnotify_git.bb b/recipes-devtools/go/go-fsnotify_git.bb
index 0826aa7f..b934ae9a 100644
--- a/recipes-devtools/go/go-fsnotify_git.bb
+++ b/recipes-devtools/go/go-fsnotify_git.bb
@@ -2,18 +2,20 @@ DESCRIPTION = "A golang registry for global request variables."
HOMEPAGE = "https://github.com/go-fsnotify/fsnotify"
SECTION = "devel/go"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=c38914c9a7ab03bb2b96d4baaee10769"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=68f2948d3c4943313d07e084a362486c"
SRCNAME = "fsnotify"
PKG_NAME = "github.com/fsnotify/${SRCNAME}"
-SRC_URI = "git://${PKG_NAME}.git"
+SRC_URI = "git://${PKG_NAME}.git;branch=main;protocol=https"
-SRCREV = "836bfd95fecc0f1511dd66bdbf2b5b61ab8b00b6"
-PV = "1.2.11+git${SRCPV}"
+SRCREV = "af855d7e6014ec848882bb2ed7d40d536872d275"
+PV = "v1.5.1+git"
S = "${WORKDIR}/git"
+inherit meta-virt-depreciated-warning
+
do_install() {
install -d ${D}${prefix}/local/go/src/${PKG_NAME}
cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/
@@ -26,4 +28,4 @@ go_fsnotify_sysroot_preprocess () {
cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
}
-FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"
+FILES:${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"