aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/go/go-distribution_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/go/go-distribution_git.bb')
-rw-r--r--recipes-devtools/go/go-distribution_git.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-devtools/go/go-distribution_git.bb b/recipes-devtools/go/go-distribution_git.bb
index 9e3f2093..598df964 100644
--- a/recipes-devtools/go/go-distribution_git.bb
+++ b/recipes-devtools/go/go-distribution_git.bb
@@ -7,13 +7,15 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=d2794c0df5b907fdace235a61
SRCNAME = "distribution"
PKG_NAME = "github.com/docker/${SRCNAME}"
-SRC_URI = "git://${PKG_NAME}.git;branch=docker/1.13;destsuffix=git/src/${PKG_NAME}"
+SRC_URI = "git://${PKG_NAME}.git;branch=docker/1.13;destsuffix=git/src/${PKG_NAME};protocol=https"
SRCREV = "28602af35aceda2f8d571bad7ca37a54cf0250bc"
-PV = "2.6.0+git${SRCPV}"
+PV = "2.6.0+git"
S = "${WORKDIR}/git"
+inherit meta-virt-depreciated-warning
+
# NO-OP the do compile rule because this recipe is source only.
do_compile() {
}
@@ -36,4 +38,4 @@ go_distribution_digeset_sysroot_preprocess () {
cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
}
-FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"
+FILES:${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"