aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/go/go-connections_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/go/go-connections_git.bb')
-rw-r--r--recipes-devtools/go/go-connections_git.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-devtools/go/go-connections_git.bb b/recipes-devtools/go/go-connections_git.bb
index 5d071b0a..33bb83bf 100644
--- a/recipes-devtools/go/go-connections_git.bb
+++ b/recipes-devtools/go/go-connections_git.bb
@@ -7,13 +7,15 @@ LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=04424bc6f5a5be60691b9824d
SRCNAME = "go-connections"
PKG_NAME = "github.com/docker/${SRCNAME}"
-SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}"
+SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME};branch=master;protocol=https"
SRCREV = "4ccf312bf1d35e5dbda654e57a9be4c3f3cd0366"
-PV = "0.2.1+git${SRCPV}"
+PV = "0.2.1+git"
S = "${WORKDIR}/git"
+inherit meta-virt-depreciated-warning
+
# NO-OP the do compile rule because this recipe is source only.
do_compile() {
}
@@ -36,4 +38,4 @@ go_connections_sysroot_preprocess () {
cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
}
-FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"
+FILES:${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"