aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/go/go-build_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/go/go-build_git.bb')
-rw-r--r--recipes-devtools/go/go-build_git.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-devtools/go/go-build_git.bb b/recipes-devtools/go/go-build_git.bb
index 29d75984..75ea40a8 100644
--- a/recipes-devtools/go/go-build_git.bb
+++ b/recipes-devtools/go/go-build_git.bb
@@ -3,9 +3,12 @@ SUMMARY = "console for runx"
DESCRIPTION = "Xen Runtime for OCI"
SRCREV_runx = "f24efd33fb18469e9cfe4d1bfe8e2c90ec8c4e93"
+SRCREV_runc = "1e7bb5b773162b57333d57f612fd72e3f8612d94"
+SRCREV_FORMAT = "runx_runc"
SRC_URI = "\
- git://github.com/lf-edge/runx;nobranch=1;name=runx \
+ git://github.com/lf-edge/runx;nobranch=1;name=runx;protocol=https \
+ git://github.com/opencontainers/runc;branch=release-1.1;name=runc;protocol=https;destsuffix=git/src/import/gobuild/go/src/github.com/opencontainers/runc \
file://0001-build-use-instead-of-go.patch \
"
SRC_URI[md5sum] = "0d701ac1e2a67d47ce7127432df2c32b"
@@ -26,7 +29,7 @@ inherit pkgconfig
GO_IMPORT = "import"
inherit go
-RDEPENDS_${PN}-dev = "bash"
+RDEPENDS:${PN}-dev = "bash"
do_compile() {
@@ -44,6 +47,7 @@ do_compile() {
export CC="${CC}"
export LD="${LD}"
export GOBIN=""
+ export GO111MODULE=off
oe_runmake GO=${GO}
}
@@ -54,4 +58,4 @@ do_install() {
install -m 755 ${B}/src/import/gobuild/serial_fd_handler ${D}${datadir}/runX/
}
-FILES_${PN} += "${datadir}/runX/*"
+FILES:${PN} += "${datadir}/runX/*"