aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/runv/runv_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/runv/runv_git.bb')
-rw-r--r--recipes-core/runv/runv_git.bb14
1 files changed, 10 insertions, 4 deletions
diff --git a/recipes-core/runv/runv_git.bb b/recipes-core/runv/runv_git.bb
index ef94f096..73cd81a6 100644
--- a/recipes-core/runv/runv_git.bb
+++ b/recipes-core/runv/runv_git.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "Hypervisor-based Runtime for OCI"
SRCREV_runv = "b360a686abc6c6e896382990ef1b93ef07c7a677"
SRC_URI = "\
- git://github.com/hyperhq/runv.git;nobranch=1;name=runv \
+ git://github.com/hyperhq/runv.git;nobranch=1;name=runv;protocol=https \
"
LICENSE = "Apache-2.0"
@@ -19,10 +19,16 @@ inherit goarch
inherit pkgconfig
inherit autotools-brokensep
+# accord with qemu
+COMPATIBLE_HOST:mipsarchn32 = "null"
+COMPATIBLE_HOST:mipsarchn64 = "null"
+COMPATIBLE_HOST:riscv32 = "null"
+COMPATIBLE_HOST:powerpc = "null"
+
PACKAGECONFIG[xen] = "--with-xen,--without-xen,"
AUTOTOOLS_SCRIPT_PATH = "${S}/src/import/"
-RDEPENDS_${PN} += " qemu hyperstart"
+RDEPENDS:${PN} += " qemu hyperstart"
do_compile() {
export GOARCH="${TARGET_GOARCH}"
@@ -76,6 +82,6 @@ do_install() {
deltask compile_ptest_base
-FILES_${PN} += "/usr/local/bin/*"
+FILES:${PN} += "/usr/local/bin/*"
-INSANE_SKIP_${PN} += "ldflags already-stripped"
+INSANE_SKIP:${PN} += "ldflags already-stripped"