aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/busybox
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/busybox')
-rw-r--r--recipes-core/busybox/busybox-initrd.bb (renamed from recipes-core/busybox/busybox-initrd_1.33.0.bb)18
-rw-r--r--recipes-core/busybox/busybox/nsenter.cfg1
-rw-r--r--recipes-core/busybox/busybox_virtualization.inc3
-rw-r--r--recipes-core/busybox/busybox_vmsep.inc2
4 files changed, 20 insertions, 4 deletions
diff --git a/recipes-core/busybox/busybox-initrd_1.33.0.bb b/recipes-core/busybox/busybox-initrd.bb
index 5ce5fa52..513ed135 100644
--- a/recipes-core/busybox/busybox-initrd_1.33.0.bb
+++ b/recipes-core/busybox/busybox-initrd.bb
@@ -1,4 +1,18 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/busybox-initrd:${COREBASE}/meta/recipes-core/busybox/busybox:${COREBASE}/meta/recipes-core/busybox/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/busybox-initrd:${COREBASE}/meta/recipes-core/busybox/busybox:${COREBASE}/meta/recipes-core/busybox/files:"
+
+def get_busybox_pv(d):
+ import re
+ corebase = d.getVar('COREBASE')
+ bb_dir = os.path.join(corebase, 'meta', 'recipes-core', 'busybox')
+ if os.path.isdir(bb_dir):
+ re_bb_name = re.compile(r"busybox_([0-9.]*)\.bb")
+ for bb_file in os.listdir(bb_dir):
+ result = re_bb_name.match(bb_file)
+ if result:
+ return result.group(1)
+ bb.fatal("Cannot find busybox recipe in %s" % bb_dir)
+
+PV := "${@get_busybox_pv(d)}"
require recipes-core/busybox/busybox_${PV}.bb
@@ -18,4 +32,4 @@ SECURITY_STRINGFORMAT = ""
SYSROOT_DIRS += "/bin"
BUSYBOX_SPLIT_SUID = "0"
-FILES_${PN} += "${sysconfdir}/init.d/*"
+FILES:${PN} += "${sysconfdir}/init.d/*"
diff --git a/recipes-core/busybox/busybox/nsenter.cfg b/recipes-core/busybox/busybox/nsenter.cfg
new file mode 100644
index 00000000..0a58df5b
--- /dev/null
+++ b/recipes-core/busybox/busybox/nsenter.cfg
@@ -0,0 +1 @@
+CONFIG_NSENTER=y
diff --git a/recipes-core/busybox/busybox_virtualization.inc b/recipes-core/busybox/busybox_virtualization.inc
index d9c4e677..652f389d 100644
--- a/recipes-core/busybox/busybox_virtualization.inc
+++ b/recipes-core/busybox/busybox_virtualization.inc
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/busybox:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/busybox:"
SRC_URI += " \
file://lspci.cfg \
@@ -7,4 +7,5 @@ SRC_URI += " \
file://mount-cifs.cfg \
file://ps-extras.cfg \
file://getopt.cfg \
+ file://nsenter.cfg \
"
diff --git a/recipes-core/busybox/busybox_vmsep.inc b/recipes-core/busybox/busybox_vmsep.inc
index d4b1e6cc..566cd6d5 100644
--- a/recipes-core/busybox/busybox_vmsep.inc
+++ b/recipes-core/busybox/busybox_vmsep.inc
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/busybox:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/busybox:"
SRC_URI += " \
file://static.cfg \
"