aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-containers/tini/tini_0.19.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/tini/tini_0.19.0.bb')
-rw-r--r--recipes-containers/tini/tini_0.19.0.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-containers/tini/tini_0.19.0.bb b/recipes-containers/tini/tini_0.19.0.bb
index 62e285df..fd90f620 100644
--- a/recipes-containers/tini/tini_0.19.0.bb
+++ b/recipes-containers/tini/tini_0.19.0.bb
@@ -6,8 +6,9 @@ it to exit all the while reaping zombies and performing signal forwarding. "
SRCREV = "b9f42a0e7bb46efea0c9e3d8610c96ab53b467f8"
SRC_URI = " \
- git://github.com/krallin/tini.git \
+ git://github.com/krallin/tini.git;branch=master;protocol=https \
file://0001-Do-not-strip-the-output-binary-allow-yocto-to-do-thi.patch \
+ file://0001-tini.c-a-function-declaration-without-a-prototype-is.patch \
"
LICENSE = "MIT"
@@ -18,7 +19,7 @@ S = "${WORKDIR}/git"
BBCLASSEXTEND = "native"
# tini links with -static, so no PIE for us
-SECURITY_CFLAGS_pn-${PN} = "${SECURITY_NO_PIE_CFLAGS}"
+SECURITY_CFLAGS:pn-${PN} = "${SECURITY_NO_PIE_CFLAGS}"
inherit cmake
@@ -29,4 +30,4 @@ do_install() {
# Tini is the currently the provider for docker-init
PROVIDES += "docker-init"
-RPROVIDES_${PN} = "docker-init"
+RPROVIDES:${PN} = "docker-init"