aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-containers/sloci-image/sloci-image_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/sloci-image/sloci-image_git.bb')
-rw-r--r--recipes-containers/sloci-image/sloci-image_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-containers/sloci-image/sloci-image_git.bb b/recipes-containers/sloci-image/sloci-image_git.bb
new file mode 100644
index 00000000..4bbf06e2
--- /dev/null
+++ b/recipes-containers/sloci-image/sloci-image_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "A simple CLI tool for packing rootfs into a single-layer OCI image"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=948cd8e59069fad992b0469af9ad7966"
+SRC_URI = "git://github.com/jirutka/sloci-image.git;branch=master;protocol=https \
+ file://0001-sloci-image-fix-variant-quoting.patch \
+ "
+
+
+DEPENDS = ""
+
+SRCREV = "4015e49763e5a738026a5bbfcf32b38b5a4fa650"
+PV = "v0.1.0+git"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ :
+}
+
+do_install() {
+ cd ${S}
+ make PREFIX="${exec_prefix}" DESTDIR=${D} install
+}
+
+CLEANBROKEN = "1"
+
+BBCLASSEXTEND = "native nativesdk"