aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-containers/cri-tools/cri-tools_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/cri-tools/cri-tools_git.bb')
-rw-r--r--recipes-containers/cri-tools/cri-tools_git.bb19
1 files changed, 11 insertions, 8 deletions
diff --git a/recipes-containers/cri-tools/cri-tools_git.bb b/recipes-containers/cri-tools/cri-tools_git.bb
index 17ddbd02..e0caf740 100644
--- a/recipes-containers/cri-tools/cri-tools_git.bb
+++ b/recipes-containers/cri-tools/cri-tools_git.bb
@@ -16,9 +16,9 @@ What is not in scope for this project? \
non-exist on the kube-apiserver. \
"
-SRCREV_cri-tools = "ec9e336fd8c21c4bab89a6aed2c4a138c8cfae75"
+SRCREV_cri-tools = "17b4dd65d660fec94d7a5a070e3e89ef640f1087"
SRC_URI = "\
- git://github.com/kubernetes-sigs/cri-tools.git;branch=master;name=cri-tools \
+ git://github.com/kubernetes-sigs/cri-tools.git;branch=master;name=cri-tools;protocol=https \
file://0001-build-allow-environmental-CGO-settings-and-pass-dont.patch \
"
@@ -27,9 +27,9 @@ LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c2
GO_IMPORT = "import"
-PV = "1.20.0+git${SRCREV_cri-tools}"
+PV = "1.29.0+git${SRCREV_cri-tools}"
-RPROVIDES_${PN} += "crictl"
+RPROVIDES:${PN} += "crictl"
PACKAGES =+ "${PN}-critest"
inherit go
@@ -63,15 +63,18 @@ do_compile() {
do_install() {
install -d ${D}${bindir}
- install -m 755 -D ${S}/src/import/_output/* ${D}/${bindir}
+ for f in $(find ${S}/src/import/build/bin/ -type f); do
+ echo "installing $f to ${D}/${bindir}"
+ install -m 755 -D $f ${D}/${bindir}
+ done
}
-FILES_${PN}-critest = "${bindir}/critest"
+FILES:${PN}-critest = "${bindir}/critest"
# don't clobber hooks.d
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
-INSANE_SKIP_${PN} += "ldflags already-stripped textrel"
+INSANE_SKIP:${PN} += "ldflags already-stripped textrel"
deltask compile_ptest_base