aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-containers/conmon/conmon_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/conmon/conmon_git.bb')
-rw-r--r--recipes-containers/conmon/conmon_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-containers/conmon/conmon_git.bb b/recipes-containers/conmon/conmon_git.bb
new file mode 100644
index 00000000..d7047ed0
--- /dev/null
+++ b/recipes-containers/conmon/conmon_git.bb
@@ -0,0 +1,32 @@
+SUMMARY = "An OCI container runtime monitor"
+SECTION = "console/utils"
+HOMEPAGE = "https://github.com/containers/conmon"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=61af0b6932ea7b12fb9142721043bc77"
+
+inherit features_check
+REQUIRED_DISTRO_FEATURES ?= "seccomp"
+
+DEPENDS = "glib-2.0 go-md2man-native libseccomp"
+
+SRCREV = "affab49967eb62f75d2a47398344ab053326289f"
+SRC_URI = "\
+ git://github.com/containers/conmon.git;branch=main;protocol=https \
+"
+
+PV = "2.1.10+git"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig
+
+export GOCACHE = "${B}/.cache"
+
+EXTRA_OEMAKE = "PREFIX=${prefix} BINDIR=${bindir} LIBEXECDIR=${libexecdir}"
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
+PACKAGECONFIG[systemd] = ",,systemd"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}