aboutsummaryrefslogtreecommitdiffstats
path: root/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf/layer.conf')
-rw-r--r--conf/layer.conf31
1 files changed, 14 insertions, 17 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 1ec7a157..7c8e3701 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -11,25 +11,17 @@ BBFILE_PRIORITY_virtualization-layer = "8"
# Custom licenses used by some packages in this layer
LICENSE_PATH += "${LAYERDIR}/files/custom-licenses"
-# The dynamic-layers directory hosts extensions and layer-specific
-# modifications.
-#
-# The .bbappend and .bb files are included if the respective layer
-# collection is available.
-BBFILES += "${@' '.join('${LAYERDIR}/dynamic-layers/%s/recipes*/*/*.bbappend' % layer \
- for layer in BBFILE_COLLECTIONS.split())}"
-BBFILES += "${@' '.join('${LAYERDIR}/dynamic-layers/%s/recipes*/*/*.bb' % layer \
- for layer in BBFILE_COLLECTIONS.split())}"
-
BBFILES_DYNAMIC += " \
raspberrypi:${LAYERDIR}/dynamic-layers/raspberrypi/*/*/*.bb \
- raspberrypi:${LAYERDIR}/dynamic-layers/rasbperrypi/*/*/*.bbappend \
+ raspberrypi:${LAYERDIR}/dynamic-layers/raspberrypi/*/*/*.bbappend \
+ xilinx:${LAYERDIR}/dynamic-layers/xilinx/*/*/*.bb \
+ xilinx:${LAYERDIR}/dynamic-layers/xilinx/*/*/*.bbappend \
"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_virtualization-layer = "1"
-LAYERSERIES_COMPAT_virtualization-layer = "zeus dunfell"
+LAYERSERIES_COMPAT_virtualization-layer = "nanbield scarthgap"
LAYERDEPENDS_virtualization-layer = " \
core \
openembedded-layer \
@@ -47,9 +39,9 @@ LAYERRECOMMENDS_virtualization-layer = " \
# Override security flags
require conf/distro/include/virt_security_flags.inc
-PREFERRED_PROVIDER_virtual/runc ?= "runc-docker"
+PREFERRED_PROVIDER_virtual/runc ?= "runc-opencontainers"
PREFERRED_PROVIDER_virtual/containerd ?= "containerd-opencontainers"
-PREFERRED_PROVIDER_virtual/docker ?= "docker-ce"
+PREFERRED_PROVIDER_virtual/docker ?= "docker-moby"
# Sanity check for meta-virtualization layer.
# Setting SKIP_META_VIRT_SANITY_CHECK to "1" would skip the bbappend files check.
@@ -60,8 +52,13 @@ INHERIT += "sanity-meta-virt"
# layer.conf load time, we delay using a special bbclass that simply includes
# the META_VIRT_CONFIG_PATH file, and likewise for the Xen and k8s configs
META_VIRT_CONFIG_PATH = "${LAYERDIR}/conf/distro/include/meta-virt-default-versions.inc"
+META_VIRT_CONTAINER_CONFIG_PATH = "${LAYERDIR}/conf/distro/include/meta-virt-container.inc"
META_VIRT_XEN_CONFIG_PATH = "${LAYERDIR}/conf/distro/include/meta-virt-xen.inc"
K8S_CONFIG_PATH = "${LAYERDIR}/conf/distro/include/k8s-versions.inc"
-USER_CLASSES_append = " meta-virt-cfg"
-USER_CLASSES_append = " meta-virt-k8s-cfg"
-USER_CLASSES_append = " meta-virt-xen-cfg"
+USER_CLASSES:append = " meta-virt-cfg"
+USER_CLASSES:append = " meta-virt-container-cfg"
+USER_CLASSES:append = " meta-virt-k8s-cfg"
+USER_CLASSES:append = " meta-virt-xen-cfg"
+USER_CLASSES:append = " meta-virt-hosts"
+
+HOSTTOOLS_NONFATAL += "getent"