aboutsummaryrefslogtreecommitdiffstats
path: root/common/recipes-core/images
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-core/images')
-rw-r--r--common/recipes-core/images/core-image-minimal-initramfs.bbappend6
-rw-r--r--common/recipes-core/images/core-image-tiny.bb37
2 files changed, 0 insertions, 43 deletions
diff --git a/common/recipes-core/images/core-image-minimal-initramfs.bbappend b/common/recipes-core/images/core-image-minimal-initramfs.bbappend
deleted file mode 100644
index 4ddca375..00000000
--- a/common/recipes-core/images/core-image-minimal-initramfs.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use initramfs-framework instead of initramfs-live*
-PACKAGE_INSTALL_remove_intel-x86-common = "initramfs-live-boot initramfs-live-install initramfs-live-install-efi"
-PACKAGE_INSTALL_append_intel-x86-common = " initramfs-framework-base initramfs-module-udev initramfs-module-setup-live initramfs-module-install-efi"
-
-# Add i915 graphics firmware
-PACKAGE_INSTALL_append_intel-x86-common = " linux-firmware-i915"
diff --git a/common/recipes-core/images/core-image-tiny.bb b/common/recipes-core/images/core-image-tiny.bb
deleted file mode 100644
index ed39fd77..00000000
--- a/common/recipes-core/images/core-image-tiny.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-SUMMARY = "A tiny image just capable of allowing a device to boot from RAM, \
-this image recipe generates an image file which rather boots from initrd than \
-from storage, it achieves this by using wic to pick up the artifacts generated \
-by the core-image-tiny-initramfs image"
-
-# The actual rootfs/initrd will be the one from core-image-tiny-initramfs, so
-# we reset IMAGE_INSTALL to avoid building other things that will be pointless
-IMAGE_INSTALL = ""
-
-# Do not pollute the initrd image with rootfs features
-IMAGE_FEATURES = ""
-
-IMAGE_LINGUAS = " "
-
-LICENSE = "MIT"
-
-IMAGE_ROOTFS_SIZE ?= "8192"
-
-IMAGE_FSTYPES = "wic"
-inherit core-image
-
-# We get some parts from image-live that we need in order to boot from initrd
-INITRD_IMAGE_LIVE ?= "core-image-tiny-initramfs"
-
-python() {
- image_b = d.getVar('IMAGE_BASENAME')
- initrd_i = d.getVar('INITRD_IMAGE_LIVE')
- if image_b == initrd_i:
- bb.error('INITRD_IMAGE_LIVE %s cannot use the requested IMAGE_FSTYPE' % initrd_i)
- bb.fatal('Check IMAGE_FSTYPES and INITRAMFS_FSTYPES settings.')
- elif initrd_i:
- d.appendVarFlag('do_image', 'depends', ' %s:do_image_complete' % initrd_i)
-}
-
-WKS_FILE_intel-corei7-64 = "core-image-tiny.wks.in"
-WKS_FILE_intel-core2-32 = "core-image-tiny.wks.in"
-WKS_FILE_intel-quark = "mktinygalileodisk.wks"