aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti')
-rw-r--r--recipes-ti/bios/ti-sysbios.inc4
-rw-r--r--recipes-ti/bios/ti-sysbios_6.41.02.41.bb4
-rw-r--r--recipes-ti/framework-components/ti-framework-components.inc3
-rw-r--r--recipes-ti/framework-components/ti-framework-components_3.40.00.02.bb2
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc3
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos_3.36.01.11.bb1
-rw-r--r--recipes-ti/xdais/ti-xdais.inc5
-rw-r--r--recipes-ti/xdais/ti-xdais_7.24.00.04.bb3
8 files changed, 17 insertions, 8 deletions
diff --git a/recipes-ti/bios/ti-sysbios.inc b/recipes-ti/bios/ti-sysbios.inc
index d04a1581..c44fec32 100644
--- a/recipes-ti/bios/ti-sysbios.inc
+++ b/recipes-ti/bios/ti-sysbios.inc
@@ -19,3 +19,7 @@ do_install() {
cp -pPrf ${S}/* ${D}${SYSBIOS_INSTALL_DIR_RECIPE}
}
+ALLOW_EMPTY_${PN} = "1"
+FILES_${PN}-dev += "${SYSBIOS_INSTALL_DIR_RECIPE}"
+
+INSANE_SKIP_${PN}-dev = "arch ldflags staticdev"
diff --git a/recipes-ti/bios/ti-sysbios_6.41.02.41.bb b/recipes-ti/bios/ti-sysbios_6.41.02.41.bb
index fcad0861..ccc6ad19 100644
--- a/recipes-ti/bios/ti-sysbios_6.41.02.41.bb
+++ b/recipes-ti/bios/ti-sysbios_6.41.02.41.bb
@@ -1,7 +1,7 @@
require ti-sysbios.inc
PV = "6_41_02_41"
-PR = "r0"
+PR = "r1"
LIC_FILES_CHKSUM = "file://bios_${PV}_manifest.html;md5=a4af75ec6d586c5267c71075eebff418"
@@ -10,5 +10,3 @@ SRC_URI[sysbiosbin.sha256sum] = "2c47b4a3aa9513d10e5811a8ac7ed1d6ce3d13df57a0bff
TI_BIN_UNPK_CMDS=""
TI_BIN_UNPK_ARGS = "--mode unattended --prefix ${WORKDIR}"
-
-INSANE_SKIP_${PN} = "installed-vs-shipped"
diff --git a/recipes-ti/framework-components/ti-framework-components.inc b/recipes-ti/framework-components/ti-framework-components.inc
index b8d3f7c3..e111ec45 100644
--- a/recipes-ti/framework-components/ti-framework-components.inc
+++ b/recipes-ti/framework-components/ti-framework-components.inc
@@ -17,4 +17,5 @@ do_install() {
INSANE_SKIP_${PN} = "ldflags"
-FILES_${PN} += "${FC_INSTALL_DIR_RECIPE}"
+ALLOW_EMPTY_${PN} = "1"
+FILES_${PN}-dev += "${FC_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/framework-components/ti-framework-components_3.40.00.02.bb b/recipes-ti/framework-components/ti-framework-components_3.40.00.02.bb
index 2dd8548b..78f764d1 100644
--- a/recipes-ti/framework-components/ti-framework-components_3.40.00.02.bb
+++ b/recipes-ti/framework-components/ti-framework-components_3.40.00.02.bb
@@ -1,7 +1,7 @@
require ti-framework-components.inc
PV = "3_40_00_02"
-PR = "r0"
+PR = "r1"
LIC_FILES_CHKSUM = "file://framework_components_${PV}_Manifest.html;md5=e3ce0b3e17175b7200f346d0c6dbbcc6"
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index fe179f5a..d14c7567 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -15,4 +15,5 @@ do_install() {
cp -pPrf ${S}/* ${D}${IPC_INSTALL_DIR_RECIPE}
}
-FILES_${PN} += "${IPC_INSTALL_DIR_RECIPE}"
+ALLOW_EMPTY_${PN} = "1"
+FILES_${PN}-dev += "${IPC_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/ipc/ti-ipc-rtos_3.36.01.11.bb b/recipes-ti/ipc/ti-ipc-rtos_3.36.01.11.bb
index 07a81363..e3f64b74 100644
--- a/recipes-ti/ipc/ti-ipc-rtos_3.36.01.11.bb
+++ b/recipes-ti/ipc/ti-ipc-rtos_3.36.01.11.bb
@@ -1,6 +1,7 @@
require ti-ipc-rtos.inc
PV = "3_36_01_11"
+PR = "r1"
LIC_FILES_CHKSUM = "file://${S}/ipc-linux.mak;beginline=1;endline=30;md5=7b327f9b710fd7c95e545b91cec79255"
diff --git a/recipes-ti/xdais/ti-xdais.inc b/recipes-ti/xdais/ti-xdais.inc
index 2e7eb13e..a7017e75 100644
--- a/recipes-ti/xdais/ti-xdais.inc
+++ b/recipes-ti/xdais/ti-xdais.inc
@@ -14,3 +14,8 @@ do_install() {
install -d ${D}${XDAIS_INSTALL_DIR_RECIPE}
cp -pPrf ${S}/* ${D}${XDAIS_INSTALL_DIR_RECIPE}
}
+
+INSANE_SKIP_${PN}-dev = "arch"
+
+ALLOW_EMPTY_${PN} = "1"
+FILES_${PN}-dev += "${XDAIS_INSTALL_DIR_RECIPE}"
diff --git a/recipes-ti/xdais/ti-xdais_7.24.00.04.bb b/recipes-ti/xdais/ti-xdais_7.24.00.04.bb
index 0f275144..8148f73a 100644
--- a/recipes-ti/xdais/ti-xdais_7.24.00.04.bb
+++ b/recipes-ti/xdais/ti-xdais_7.24.00.04.bb
@@ -1,10 +1,9 @@
require ti-xdais.inc
PV = "7_24_00_04"
+PR = "r1"
LIC_FILES_CHKSUM = "file://xdais_7_24_00_04_Manifest.html;md5=fd16442230745f0877cfe1c622669fd6"
SRC_URI[xdaistarball.md5sum] = "f7514085b531f2ae49b37b30194e4989"
SRC_URI[xdaistarball.sha256sum] = "79fd30377ab4c497292aeefb0565f81703d9020d1242b02ca9968c561e0de9a1"
-
-INSANE_SKIP_${PN} = "installed-vs-shipped"