aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti/multiprocmgr
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/multiprocmgr')
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb44
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-test_git.bb29
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr.inc21
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr/mpmsrv-daemon.service14
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr_git.bb44
5 files changed, 0 insertions, 152 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
deleted file mode 100644
index 7a6e0f63..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr-rtos_git.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-SUMMARY = "TI Multiproc Manager (RTOS) for KeyStone II"
-DESCRIPTION = "Provides download, debug and other utilities for other cores in the SOC like DSP"
-
-require recipes-ti/includes/ti-paths.inc
-require recipes-ti/multiprocmgr/multiprocmgr.inc
-
-DEPENDS = "ti-cgt6x-native"
-
-PR = "${INC_PR}.2"
-
-PACKAGES =+ "${PN}-test"
-FILES_${PN}-test = "${datadir}/ti/examples/mpm/test/filetestdemo/c66x/demo_loopback/build/bin/*.out \
- ${datadir}/ti/examples/mpm/test/sync_test/c66x/bin/*.out"
-
-EXTRA_OEMAKE = "LOCAL_SYSROOT="${STAGING_DIR_TARGET}" \
- C6X_GEN_INSTALL_PATH="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \
- "
-
-do_compile() {
- oe_runmake c66x
- oe_runmake test_c66x
-}
-
-do_install() {
- CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership"
- install -d ${D}${MPM_INSTALL_DIR_RECIPE}
- cp ${CP_ARGS} ${S}/* ${D}${MPM_INSTALL_DIR_RECIPE}
-
- # Copy C66x binaries
- install -d ${D}${datadir}/ti/examples/mpm/test/filetestdemo/c66x/demo_loopback/build/bin
- cp ${S}/test/filetestdemo/c66x/demo_loopback/build/bin/*.out \
- ${D}${datadir}/ti/examples/mpm/test/filetestdemo/c66x/demo_loopback/build/bin/
- install -d ${D}${datadir}/ti/examples/mpm/test/sync_test/c66x/bin
- cp ${S}/test/sync_test/c66x/bin/*.out \
- ${D}${datadir}/ti/examples/mpm/test/sync_test/c66x/bin/
-}
-
-FILES_${PN}-dev += "${MPM_INSTALL_DIR_RECIPE}"
-INSANE_SKIP_${PN}-dev = "arch"
-INSANE_SKIP_${PN}-test = "arch"
-
-RDEPENDS_${PN}-dev = "bash"
-
-ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
deleted file mode 100644
index 7c3f9e1b..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "TI Multiproc Manager test code"
-
-include multiprocmgr.inc
-
-PR = "${INC_PR}.2"
-
-DEPENDS = "multiprocmgr cmem"
-RDEPENDS_${PN} = "multiprocmgr mpm-transport cmem"
-RDEPENDS_${PN} += "multiprocmgr-rtos-test bash"
-
-FILES_${PN} += "\
- ${datadir}/ti/examples/mpm \
-"
-
-FILES_${PN}-dbg += "\
- ${datadir}/ti/examples/mpm/*/.debug \
-"
-
-do_compile() {
- oe_runmake -C ${S} test
-}
-
-do_install() {
- # Copy Sources and binary
- install -d ${D}${datadir}/ti/examples/mpm/src
- cp -r ${S}/src/mailbox ${D}${datadir}/ti/examples/mpm/src
- cp -r ${S}/src/sync ${D}${datadir}/ti/examples/mpm/src
- cp -r ${S}/test ${D}${datadir}/ti/examples/mpm
-}
diff --git a/recipes-ti/multiprocmgr/multiprocmgr.inc b/recipes-ti/multiprocmgr/multiprocmgr.inc
deleted file mode 100644
index 64fb6f6f..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr.inc
+++ /dev/null
@@ -1,21 +0,0 @@
-HOMEPAGE = "http://git.ti.com/cgit/cgit.cgi/keystone-linux/multi-proc-manager.git"
-LICENSE = "BSD-3-Clause & MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fce208c498eb9669223724dc9c1d8fe4"
-SECTION = "console"
-COMPATIBLE_MACHINE = "keystone"
-
-MULTIPROCMGR_GIT_URI = "git://git.ti.com/keystone-linux/multi-proc-manager.git"
-MULTIPROCMGR_GIT_PROTOCOL = "git"
-MULTIPROCMGR_GIT_BRANCH = "master"
-
-# The following commits correspond to DEV.MPM-3.00.05.00
-MULTIPROCMGR_SRCREV = "810d8a31c797d07abe808cb3fa89465fa934d4dd"
-
-PV = "3.0.5.0"
-INC_PR = "r1"
-
-BRANCH = "${MULTIPROCMGR_GIT_BRANCH}"
-SRC_URI = "${MULTIPROCMGR_GIT_URI};protocol=${MULTIPROCMGR_GIT_PROTOCOL};branch=${BRANCH}"
-SRCREV = "${MULTIPROCMGR_SRCREV}"
-
-S = "${WORKDIR}/git"
diff --git a/recipes-ti/multiprocmgr/multiprocmgr/mpmsrv-daemon.service b/recipes-ti/multiprocmgr/multiprocmgr/mpmsrv-daemon.service
deleted file mode 100644
index 40eb4650..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr/mpmsrv-daemon.service
+++ /dev/null
@@ -1,14 +0,0 @@
-[Unit]
-Description=TI Multiproc Manager
-
-[Service]
-ExecStartPre=/sbin/modprobe keystone_remoteproc
-ExecStartPre=/sbin/modprobe keystone_dsp_mem
-ExecStartPre=/sbin/modprobe uio_module_drv
-
-Type=forking
-PIDFile=/var/run/mpm/pid
-ExecStart=/usr/bin/mpmsrv
-
-[Install]
-WantedBy=basic.target
diff --git a/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
deleted file mode 100644
index 07512603..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr_git.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-SUMMARY = "TI Multiproc Manager for KeyStone II"
-DESCRIPTION = "Provides download, debug and other utilities for other cores in the SOC like DSP"
-
-include multiprocmgr.inc
-
-SRC_URI += " \
- file://mpmsrv-daemon.service \
-"
-
-PR = "${INC_PR}.2"
-
-DEPENDS = "mpm-transport libdaemon virtual/kernel cmem"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-INITSCRIPT_NAME = "mpmsrv-daemon.sh"
-INITSCRIPT_PARAMS = "defaults 10"
-
-SYSTEMD_SERVICE_${PN} = "mpmsrv-daemon.service"
-
-inherit update-rc.d systemd
-
-do_install() {
- install -d ${D}${bindir}/
- install -c -m 755 ${S}/bin/mpmsrv ${D}${bindir}/mpmsrv
- install -c -m 755 ${S}/bin/mpmcl ${D}${bindir}/mpmcl
-
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/mpmsrv-daemon.service ${D}${systemd_system_unitdir}
- install -d ${D}${sysconfdir}/init.d/
- install -c -m 755 ${S}/scripts/mpmsrv-daemon.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
-
- install -d ${D}${sysconfdir}/mpm/
- install -c -m 755 ${S}/scripts/crash_callback.sh ${D}${sysconfdir}/mpm/crash_callback.sh
-
- install -d ${D}${includedir}/
- install -c -m 755 ${S}/include/* ${D}${includedir}/
-
- install -d ${D}${libdir}/
- cp -a ${S}/lib/* ${D}${libdir}/
- chown -R root:root ${D}${libdir}/
-}
-
-INSANE_SKIP_${PN} = "ldflags"