aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc/ti-ipc-examples_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/ipc/ti-ipc-examples_git.bb')
-rw-r--r--recipes-ti/ipc/ti-ipc-examples_git.bb46
1 files changed, 0 insertions, 46 deletions
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb
deleted file mode 100644
index 43e45e64..00000000
--- a/recipes-ti/ipc/ti-ipc-examples_git.bb
+++ /dev/null
@@ -1,46 +0,0 @@
-DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running linux"
-require ti-ipc-examples.inc
-
-DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
-
-DEPENDS_append_am65xx = " sciclient-rtos"
-
-do_compile_append() {
-
- if [ "${PLATFORM}" != "UNKNOWN" ]; then
- oe_runmake extract HOSTOS="bios" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
-
- for alt_platform in ${ALT_PLATFORM}; do
- oe_runmake extract PLATFORM="${alt_platform}" HOSTOS="bios" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- done
- oe_runmake -C examples all HOSTOS="bios" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- for alt_platform in ${ALT_PLATFORM}; do
- oe_runmake -C examples all HOSTOS="bios" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" PLATFORM="${alt_platform}"
- done
- fi
-}
-
-do_install_append() {
- if [ "${PLATFORM}" != "UNKNOWN" ]; then
- # Install directory for bios examples
- install -d ${D}/ipc_${IPC_VERSION}/examples/bios
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
- oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/bios"
-
- for alt_platform in ${ALT_PLATFORM}; do
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
- PLATFORM="${alt_platform}"
- oe_runmake -C examples install_rov IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- HOSTOS="bios" EXEC_DIR="${D}/ipc_${IPC_VERSION}/examples/${alt_platform}/bios" \
- PLATFORM="${alt_platform}"
- done
- fi
-}
-
-FILES_${PN} += "ipc_*"