aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ti/ipc/ti-ipc-examples-linux_git.bb')
-rw-r--r--recipes-ti/ipc/ti-ipc-examples-linux_git.bb47
1 files changed, 0 insertions, 47 deletions
diff --git a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb b/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
deleted file mode 100644
index 471d7ff2..00000000
--- a/recipes-ti/ipc/ti-ipc-examples-linux_git.bb
+++ /dev/null
@@ -1,47 +0,0 @@
-DESCRIPTION = "TI Inter Process Communication (IPC) examples with Host running bios"
-require ti-ipc-examples.inc
-
-DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native"
-
-do_compile_append() {
-
- if [ "${PLATFORM}" != "UNKNOWN" ]; then
- oe_runmake extract HOSTOS="linux" IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
-
- if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake extract PLATFORM="${ALT_PLATFORM}" HOSTOS="linux" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
- fi
- oe_runmake -C examples all HOSTOS="linux" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}"
-
- if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake -C examples all HOSTOS="linux" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- PLATFORM="${ALT_PLATFORM}"
- fi
- fi
-}
-
-do_install_append() {
- cd ${S_ipc-examples}/src
-
- if [ "${PLATFORM}" != "UNKNOWN" ]; then
- # Install directory for linux examples
- install -d ${D}${bindir}/ipc/examples
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples"
-
- if [ ! -z ${ALT_PLATFORM} ]; then
- oe_runmake -C examples install IPC_INSTALL_DIR="${IPC_INSTALL_DIR}" \
- LINUX_SYSROOT_DIR="${STAGING_INCDIR}" \
- HOSTOS="linux" EXEC_DIR="${D}/${bindir}/ipc/examples" \
- PLATFORM="${ALT_PLATFORM}"
- fi
- fi
-}
-
-FILES_${PN} += "${bindir}/*"