aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kselftests/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/kselftests/files')
-rw-r--r--recipes-kernel/kselftests/files/0001-selftests-add-ptp-to-TARGETS.patch25
-rw-r--r--recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch32
-rw-r--r--recipes-kernel/kselftests/files/0001-selftests-gpio-use-pkg-config.patch53
-rw-r--r--recipes-kernel/kselftests/files/0001-selftests-lib-allow-to-override-CC-in-the-top-level-Makefile.patch22
-rw-r--r--recipes-kernel/kselftests/files/0001-selftests-net-use-LDLIBS-to-link-against-libnuma.patch24
-rw-r--r--recipes-kernel/kselftests/files/0001-selftests-seccomp-use-LDLIBS-to-link-against-libpthread.patch23
-rw-r--r--recipes-kernel/kselftests/files/0001-selftests-sigaltstack-fix-packaging.patch26
-rw-r--r--recipes-kernel/kselftests/files/0001-selftests-timers-use-LDLIBS-to-link-against-libpthread.patch23
8 files changed, 0 insertions, 228 deletions
diff --git a/recipes-kernel/kselftests/files/0001-selftests-add-ptp-to-TARGETS.patch b/recipes-kernel/kselftests/files/0001-selftests-add-ptp-to-TARGETS.patch
deleted file mode 100644
index 4c4a00e7..00000000
--- a/recipes-kernel/kselftests/files/0001-selftests-add-ptp-to-TARGETS.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 9e1b0f0d7148524c226befdef90849f9e143ef66 Mon Sep 17 00:00:00 2001
-From: Denys Dmytriyenko <denys@ti.com>
-Date: Fri, 17 May 2019 18:20:21 +0000
-Subject: [PATCH] selftests: add "ptp" to TARGETS
-
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
----
- tools/testing/selftests/Makefile | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/tools/testing/selftests/Makefile b/tools/testing/selftests/Makefile
-index 831022b1..6bd7cf81 100644
---- a/tools/testing/selftests/Makefile
-+++ b/tools/testing/selftests/Makefile
-@@ -20,6 +20,7 @@ TARGETS += net
- TARGETS += nsfs
- TARGETS += powerpc
- TARGETS += pstore
-+TARGETS += ptp
- TARGETS += ptrace
- TARGETS += seccomp
- TARGETS += sigaltstack
---
-2.17.1
-
diff --git a/recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch b/recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch
deleted file mode 100644
index 8b7aa25a..00000000
--- a/recipes-kernel/kselftests/files/0001-selftests-breakpoints-allow-to-cross-compile-for-aar.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 607192f42d65e17f55fc6e85c00019bf71b18770 Mon Sep 17 00:00:00 2001
-From: Fathi Boudra <fathi.boudra@linaro.org>
-Date: Wed, 22 Mar 2017 19:47:32 +0200
-Subject: [PATCH 1/1] selftests: breakpoints: allow to cross-compile for
- aarch64/arm64
-
-To build breakpoint_test_arm64, ARCH value is only tested for "aarch64".
-It covers only the native build because it's computed from uname -m output.
-For cross-compilation, ARCH is set to arm64 and prevent to cross-compile
-the test.
-Fix the test to allow both native and cross-compilation of the test.
-
-Note: glibc is missing several of the TRAP_* constants in the userspace
- definitions. Specifically TRAP_BRANCH and TRAP_HWBKPT.
- See https://sourceware.org/bugzilla/show_bug.cgi?id=21286
-
-Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
----
- tools/testing/selftests/breakpoints/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/tools/testing/selftests/breakpoints/Makefile
-+++ b/tools/testing/selftests/breakpoints/Makefile
-@@ -5,7 +5,7 @@ ARCH ?= $(shell echo $(uname_M) | sed -e
- ifeq ($(ARCH),x86)
- TEST_PROGS := breakpoint_test
- endif
--ifeq ($(ARCH),aarch64)
-+ifneq (,$(filter $(ARCH),aarch64 arm64))
- TEST_PROGS := breakpoint_test_arm64
- endif
-
diff --git a/recipes-kernel/kselftests/files/0001-selftests-gpio-use-pkg-config.patch b/recipes-kernel/kselftests/files/0001-selftests-gpio-use-pkg-config.patch
deleted file mode 100644
index 0d0bfc7e..00000000
--- a/recipes-kernel/kselftests/files/0001-selftests-gpio-use-pkg-config.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From: Fathi Boudra <fathi.boudra@linaro.org>
-Subject: [PATCH] selftests: gpio: use pkg-config
-
-Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
----
----
- tools/testing/selftests/gpio/Makefile | 31 ++++++++++++++++++-------------
- 1 file changed, 18 insertions(+), 13 deletions(-)
-
---- a/tools/testing/selftests/gpio/Makefile
-+++ b/tools/testing/selftests/gpio/Makefile
-@@ -1,23 +1,28 @@
-+CFLAGS += -O2 -g -std=gnu99 -Wall
-+CFLAGS += -I../../../../usr/include/
-+CFLAGS += $(shell pkg-config --cflags mount)
-+LDLIBS += $(shell pkg-config --libs mount)
-
- TEST_PROGS := gpio-mockup.sh
--TEST_FILES := gpio-mockup-sysfs.sh $(BINARIES)
--BINARIES := gpio-mockup-chardev
-+TEST_PROGS_EXTENDED := gpio-mockup-chardev
-+TEST_FILES := gpio-mockup-sysfs.sh
-
--include ../lib.mk
-+GPIODIR := ../../../gpio
-+GPIOOBJ := gpio-utils.o
-+GPIOINC := gpio.h
-
--all: $(BINARIES)
-+all: $(GPIOINC) $(TEST_PROGS_EXTENDED)
-
- clean:
-- $(RM) $(BINARIES)
--
--CFLAGS += -O2 -g -std=gnu99 -Wall -I../../../../usr/include/
--LDLIBS += -lmount -I/usr/include/libmount
-+ $(RM) $(TEST_PROGS_EXTENDED)
-+ $(MAKE) -C $(GPIODIR) clean
-
--$(BINARIES): ../../../gpio/gpio-utils.o ../../../../usr/include/linux/gpio.h
-+include ../lib.mk
-
--../../../gpio/gpio-utils.o:
-- make ARCH=$(ARCH) CROSS_COMPILE=$(CROSS_COMPILE) -C ../../../gpio
-+$(TEST_PROGS_EXTENDED): $(GPIODIR)/$(GPIOOBJ)
-
--../../../../usr/include/linux/gpio.h:
-- make -C ../../../.. headers_install INSTALL_HDR_PATH=$(shell pwd)/../../../../usr/
-+$(GPIODIR)/$(GPIOOBJ):
-+ $(MAKE) -C $(GPIODIR)
-
-+$(GPIOINC):
-+ $(MAKE) -C ../../../.. headers_install
diff --git a/recipes-kernel/kselftests/files/0001-selftests-lib-allow-to-override-CC-in-the-top-level-Makefile.patch b/recipes-kernel/kselftests/files/0001-selftests-lib-allow-to-override-CC-in-the-top-level-Makefile.patch
deleted file mode 100644
index 9d48fd5d..00000000
--- a/recipes-kernel/kselftests/files/0001-selftests-lib-allow-to-override-CC-in-the-top-level-Makefile.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 2e93b68257aa88ccdc127ca119304a5f4c76b7c5 Mon Sep 17 00:00:00 2001
-From: Fathi Boudra <fathi.boudra@linaro.org>
-Date: Wed, 22 Mar 2017 17:36:53 +0200
-Subject: [PATCH] selftests: lib: allow to override CC in the top-level Makefile
-
-Relax CC assignment to allow to override CC in the top-level Makefile.
-
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
----
- tools/testing/selftests/lib.mk | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/tools/testing/selftests/lib.mk
-+++ b/tools/testing/selftests/lib.mk
-@@ -1,6 +1,6 @@
- # This mimics the top-level Makefile. We do it explicitly here so that this
- # Makefile can operate with or without the kbuild infrastructure.
--CC := $(CROSS_COMPILE)gcc
-+CC ?= $(CROSS_COMPILE)gcc
-
- define RUN_TESTS
- @for TEST in $(TEST_PROGS); do \
diff --git a/recipes-kernel/kselftests/files/0001-selftests-net-use-LDLIBS-to-link-against-libnuma.patch b/recipes-kernel/kselftests/files/0001-selftests-net-use-LDLIBS-to-link-against-libnuma.patch
deleted file mode 100644
index da5ac00c..00000000
--- a/recipes-kernel/kselftests/files/0001-selftests-net-use-LDLIBS-to-link-against-libnuma.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Subject: [PATCH] selftests: net: use LDLIBS to link against libnuma
-
-Use the same fixup as used for timers test:
-use LDLIBS to properly link against libnuma.
-
-Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
----
- tools/testing/selftests/net/Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/tools/testing/selftests/net/Makefile
-+++ b/tools/testing/selftests/net/Makefile
-@@ -9,9 +9,9 @@ NET_PROGS += reuseport_bpf reuseport_bpf
- NET_PROGS += reuseport_dualstack
-
- all: $(NET_PROGS)
--reuseport_bpf_numa: LDFLAGS += -lnuma
-+reuseport_bpf_numa: LDLIBS += -lnuma
- %: %.c
-- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
-+ $(CC) $(CFLAGS) $(LDLIBS) -o $@ $^
-
- TEST_PROGS := run_netsocktests run_afpackettests test_bpf.sh
- TEST_FILES := $(NET_PROGS)
diff --git a/recipes-kernel/kselftests/files/0001-selftests-seccomp-use-LDLIBS-to-link-against-libpthread.patch b/recipes-kernel/kselftests/files/0001-selftests-seccomp-use-LDLIBS-to-link-against-libpthread.patch
deleted file mode 100644
index 447a61bb..00000000
--- a/recipes-kernel/kselftests/files/0001-selftests-seccomp-use-LDLIBS-to-link-against-libpthread.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 0fd29435ce41d60cdb3b5e06e491500ddc54a86b Mon Sep 17 00:00:00 2001
-From: Fathi Boudra <fathi.boudra@linaro.org>
-Date: Wed, 22 Mar 2017 17:39:37 +0200
-Subject: [PATCH] selftests: seccomp: use LDLIBS to link against libpthread
-
-Use the same fixup as used for timers test:
-use LDLIBS to properly link against libpthread.
-
-Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
----
- tools/testing/selftests/seccomp/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/tools/testing/selftests/seccomp/Makefile
-+++ b/tools/testing/selftests/seccomp/Makefile
-@@ -1,6 +1,6 @@
- TEST_PROGS := seccomp_bpf
- CFLAGS += -Wl,-no-as-needed -Wall
--LDFLAGS += -lpthread
-+LDLIBS += -lpthread
-
- all: $(TEST_PROGS)
-
diff --git a/recipes-kernel/kselftests/files/0001-selftests-sigaltstack-fix-packaging.patch b/recipes-kernel/kselftests/files/0001-selftests-sigaltstack-fix-packaging.patch
deleted file mode 100644
index 4cc5907a..00000000
--- a/recipes-kernel/kselftests/files/0001-selftests-sigaltstack-fix-packaging.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From b0448d7816ca561b6470dc50fc1621aec2620f57 Mon Sep 17 00:00:00 2001
-From: Fathi Boudra <fathi.boudra@linaro.org>
-Date: Wed, 22 Mar 2017 17:40:11 +0200
-Subject: [PATCH] selftests: sigaltstack: fix packaging
-
-sigaltstack was not using TEST_PROGS resulting in binary not being installed.
-
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
----
- tools/testing/selftests/sigaltstack/Makefile | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
---- a/tools/testing/selftests/sigaltstack/Makefile
-+++ b/tools/testing/selftests/sigaltstack/Makefile
-@@ -1,8 +1,8 @@
- CFLAGS = -Wall
--BINARIES = sas
--all: $(BINARIES)
-+TEST_PROGS = sas
-+all: $(TEST_PROGS)
-
- include ../lib.mk
-
- clean:
-- rm -rf $(BINARIES)
-+ rm -rf $(TEST_PROGS)
diff --git a/recipes-kernel/kselftests/files/0001-selftests-timers-use-LDLIBS-to-link-against-libpthread.patch b/recipes-kernel/kselftests/files/0001-selftests-timers-use-LDLIBS-to-link-against-libpthread.patch
deleted file mode 100644
index 9f12c6ca..00000000
--- a/recipes-kernel/kselftests/files/0001-selftests-timers-use-LDLIBS-to-link-against-libpthread.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From b0448d7816ca561b6470dc50fc1621aec2620f57 Mon Sep 17 00:00:00 2001
-From: Fathi Boudra <fathi.boudra@linaro.org>
-Date: Wed, 22 Mar 2017 17:40:11 +0200
-Subject: [PATCH] selftests: timers: use LDLIBS to link against libpthread
-
-use LDLIBS to properly link against libpthread.
-
-Signed-off-by: Denys Dmytriyenko <denys@ti.com>
----
- tools/testing/selftests/timers/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/tools/testing/selftests/timers/Makefile
-+++ b/tools/testing/selftests/timers/Makefile
-@@ -1,7 +1,7 @@
- CC = $(CROSS_COMPILE)gcc
- BUILD_FLAGS = -DKTEST
- CFLAGS += -O3 -Wl,-no-as-needed -Wall $(BUILD_FLAGS)
--LDFLAGS += -lrt -lpthread
-+LDLIBS += -lrt -lpthread
-
- # these are all "safe" tests that don't modify
- # system time or require escalated privledges