aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/boot-monitor/boot-monitor_git.bb4
-rw-r--r--recipes-bsp/cmem/cmem-mod_git.bb2
-rw-r--r--recipes-bsp/cmem/cmem.inc2
-rw-r--r--recipes-bsp/cmem/cmem_git.bb2
-rw-r--r--recipes-bsp/hplib/hplib-mod_git.bb2
-rw-r--r--recipes-bsp/hplib/hplib.inc2
-rw-r--r--recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb3
-rw-r--r--recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-keystone_2013.01.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot_2014.07.bb2
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv_git.bb4
16 files changed, 26 insertions, 20 deletions
diff --git a/recipes-bsp/boot-monitor/boot-monitor_git.bb b/recipes-bsp/boot-monitor/boot-monitor_git.bb
index 72dc9241..678e99c3 100644
--- a/recipes-bsp/boot-monitor/boot-monitor_git.bb
+++ b/recipes-bsp/boot-monitor/boot-monitor_git.bb
@@ -6,8 +6,8 @@ COMPATIBLE_MACHINE = "keystone"
SRC_URI = "git://git.ti.com/keystone-linux/boot-monitor.git;protocol=git;branch=${BRANCH}"
-PV = "2.0"
-PR = "r2+gitr${SRCPV}"
+PV = "2.0+git${SRCPV}"
+PR = "r2"
BRANCH = "master"
diff --git a/recipes-bsp/cmem/cmem-mod_git.bb b/recipes-bsp/cmem/cmem-mod_git.bb
index 0cc0b464..b36eb096 100644
--- a/recipes-bsp/cmem/cmem-mod_git.bb
+++ b/recipes-bsp/cmem/cmem-mod_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Kernel module for contiguous memory allocation from userspace"
include cmem.inc
# This package builds a kernel module, use kernel PR as base and append a local
-MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}"
+MACHINE_KERNEL_PR_append = "b"
PR = "${MACHINE_KERNEL_PR}"
inherit module
diff --git a/recipes-bsp/cmem/cmem.inc b/recipes-bsp/cmem/cmem.inc
index ff7a8a04..bbb86b05 100644
--- a/recipes-bsp/cmem/cmem.inc
+++ b/recipes-bsp/cmem/cmem.inc
@@ -7,6 +7,8 @@ BRANCH ?= "master"
# This corresponds to version 4.10.00.01
SRCREV = "0d2fac7187ca1f6af62a98dee5b3621908cf5831"
+PV = "4.10.00.01+git${SRCPV}"
+
SRC_URI = "git://git.ti.com/ipc/ludev.git;protocol=git;branch=${BRANCH}"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/cmem/cmem_git.bb b/recipes-bsp/cmem/cmem_git.bb
index 540c2f63..b30029d6 100644
--- a/recipes-bsp/cmem/cmem_git.bb
+++ b/recipes-bsp/cmem/cmem_git.bb
@@ -4,7 +4,7 @@ include cmem.inc
RDEPENDS_${PN} = "cmem-mod"
-PR = "r1+gitr${SRCPV}"
+PR = "r1"
PACKAGES =+ "${PN}-test"
diff --git a/recipes-bsp/hplib/hplib-mod_git.bb b/recipes-bsp/hplib/hplib-mod_git.bb
index acef1ce5..6603a2eb 100644
--- a/recipes-bsp/hplib/hplib-mod_git.bb
+++ b/recipes-bsp/hplib/hplib-mod_git.bb
@@ -7,7 +7,7 @@ DEPENDS = "hplib"
include hplib.inc
# This package builds a kernel module, use kernel PR as base and append a local
-MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}"
+MACHINE_KERNEL_PR_append = "a"
PR = "${MACHINE_KERNEL_PR}"
S ="${WORKDIR}/git/ti/runtime/hplib/module"
diff --git a/recipes-bsp/hplib/hplib.inc b/recipes-bsp/hplib/hplib.inc
index de5b2b7a..b3a62b82 100644
--- a/recipes-bsp/hplib/hplib.inc
+++ b/recipes-bsp/hplib/hplib.inc
@@ -7,4 +7,4 @@ SRC_URI = "git://git.ti.com/keystone-rtos/hplib.git;protocol=git;branch=${BRANCH
# Below Commit ID corresponds to "DEV.HPLIB.01.01.00.05"
SRCREV = "97c2ce177c78c0f7a861c8dc9ac10657d85eae36"
-PV = "01.01.00.05"
+PV = "01.01.00.05+git${SRCPV}"
diff --git a/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb b/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb
index 1a418d7c..a837b356 100644
--- a/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb
+++ b/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb
@@ -7,8 +7,9 @@ COMPATIBLE_MACHINE = "omapl138"
INHIBIT_PACKAGE_STRIP = "1"
-MACHINE_KERNEL_PR_append = "b+svnr${SRCPV}"
+MACHINE_KERNEL_PR_append = "b"
PR = "${MACHINE_KERNEL_PR}"
+PV_append = "+svn${SRCPV}"
SRC_URI = "svn://gforge.ti.com/svn/pru_sw/;module=trunk;protocol=https;user=anonymous;pswd=''"
diff --git a/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb b/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
index ad1d5efb..43eed7d1 100644
--- a/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
+++ b/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
@@ -19,8 +19,9 @@ S = "${WORKDIR}/trunk"
inherit module
-MACHINE_KERNEL_PR_append = "b+svnr${SRCPV}"
+MACHINE_KERNEL_PR_append = "b"
PR = "${MACHINE_KERNEL_PR}"
+PV_append = "+svn${SRCPV}"
EXTRA_OEMAKE += "KERNEL_DIR=${STAGING_KERNEL_DIR}"
diff --git a/recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb
index cb2e850e..8f805bc8 100644
--- a/recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb
+++ b/recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb
@@ -6,7 +6,8 @@ COMPATIBLE_MACHINE = "ti33x"
DEFAULT_PREFERENCE = "-1"
-PR = "r6+gitr${SRCPV}"
+PR = "r6"
+PV_append = "+git${SRCPV}"
SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
diff --git a/recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb
index 07df497b..3a22864a 100644
--- a/recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb
+++ b/recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb
@@ -2,7 +2,8 @@ require u-boot-ti.inc
DESCRIPTION = "u-boot bootloader for TI devices supported by the GLSDK product"
-PR = "r1+gitr${SRCPV}"
+PR = "r1"
+PV_append = "+git${SRCPV}"
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes-bsp/u-boot/u-boot-keystone_2013.01.bb b/recipes-bsp/u-boot/u-boot-keystone_2013.01.bb
index a464d145..80f4c345 100644
--- a/recipes-bsp/u-boot/u-boot-keystone_2013.01.bb
+++ b/recipes-bsp/u-boot/u-boot-keystone_2013.01.bb
@@ -4,7 +4,8 @@ DESCRIPTION = "u-boot bootloader for Multi-Core BU devices"
COMPATIBLE_MACHINE = "keystone"
-PR = "r5+gitr${SRCPV}"
+PR = "r5"
+PV_append = "+git${SRCPV}"
# Tag "K2_UBOOT_2013_01_14.09"
SRCREV = "f9bc365551ff8c685bf6134d795576713fec0917"
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb
index ea72e4df..821e9ed7 100644
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb
+++ b/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb
@@ -2,7 +2,8 @@ require u-boot-ti.inc
DESCRIPTION = "u-boot bootloader for TI devices"
-PR = "r5+gitr${SRCPV}"
+PR = "r5"
+PV_append = "+git${SRCPV}"
SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb
index d954db47..de44faa5 100644
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb
+++ b/recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb
@@ -4,8 +4,8 @@ DESCRIPTION = "u-boot bootloader for TI devices"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
-PV = "2013.10"
-PR = "r8+gitr${SRCPV}"
+PR = "r8"
+PV_append = "+git${SRCPV}"
SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb
index eff86800..09dfdfa5 100644
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb
+++ b/recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb
@@ -7,8 +7,8 @@ DESCRIPTION = "u-boot bootloader for TI devices"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
-PV = "2014.07"
-PR = "r12+gitr${SRCPV}"
+PR = "r12"
+PV_append = "+git${SRCPV}"
SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
diff --git a/recipes-bsp/u-boot/u-boot_2014.07.bb b/recipes-bsp/u-boot/u-boot_2014.07.bb
index 91406f92..6cd8acd4 100644
--- a/recipes-bsp/u-boot/u-boot_2014.07.bb
+++ b/recipes-bsp/u-boot/u-boot_2014.07.bb
@@ -11,8 +11,6 @@ DEFAULT_PREFERENCE = "-1"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
-PV = "2014.07"
-
SRC_URI = "git://git.denx.de/u-boot.git;protocol=git;branch=${BRANCH}"
BRANCH ?= "master"
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
index b7a26a1d..b2475278 100644
--- a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
+++ b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016"
BRANCH ?= "master"
# This corresponds to version 01.00.02.01
SRCREV = "c1988446e3364af4df7cd877e6536f0c6647d7bb"
-PV = "1.0.2.1"
+PV = "1.0.2.1+git${SRCPV}"
SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}"
# This package builds a kernel module, use kernel PR as base and append a local
-MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}"
+MACHINE_KERNEL_PR_append = "b"
PR = "${MACHINE_KERNEL_PR}"
S = "${WORKDIR}/git"