aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ti-sci-fw/ti-sci-fw_0.1.1.50.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/ti-sci-fw/ti-sci-fw_0.1.1.50.bb')
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_0.1.1.50.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_0.1.1.50.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_0.1.1.50.bb
new file mode 100644
index 00000000..9e68fdff
--- /dev/null
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_0.1.1.50.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "TI SCI firmware"
+
+LICENSE = "TI-TFL"
+LIC_FILES_CHKSUM = "file://LICENCE.ti-keystone;md5=3a86335d32864b0bef996bee26cc0f2c"
+
+PV = "0.1.1.50"
+PR = "r2"
+
+CLEANBROKEN = "1"
+
+COMPATIBLE_MACHINE = "k2g"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+SRCREV = "ab507546f0f3f217f4c782a20845856e14b38224"
+BRANCH ?= "ti-linux-firmware"
+
+SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
+
+S = "${WORKDIR}/git"
+TARGET = "ti-sci-firmware-k2g.bin"
+
+do_install() {
+ install -d ${D}/boot
+ install -m 0644 ${S}/ti-keystone/${TARGET} ${D}/boot/${TARGET}
+}
+
+FILES_${PN} = "/boot"
+
+inherit deploy
+
+do_deploy () {
+ install -d ${DEPLOYDIR}
+ install -m 0644 ${S}/ti-keystone/${TARGET} ${DEPLOYDIR}/${TARGET}
+}
+
+addtask deploy before do_build after do_compile