aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pa-lld
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/pa-lld')
-rw-r--r--recipes-bsp/pa-lld/pa-lld-rtos_git.bb12
-rw-r--r--recipes-bsp/pa-lld/pa-lld-test_git.bb28
-rw-r--r--recipes-bsp/pa-lld/pa-lld.inc24
-rw-r--r--recipes-bsp/pa-lld/pa-lld_git.bb24
4 files changed, 0 insertions, 88 deletions
diff --git a/recipes-bsp/pa-lld/pa-lld-rtos_git.bb b/recipes-bsp/pa-lld/pa-lld-rtos_git.bb
deleted file mode 100644
index e415f36c..00000000
--- a/recipes-bsp/pa-lld/pa-lld-rtos_git.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-SUMMARY = "TI RTOS low level driver for Packet Accelerator (PA)"
-
-inherit ti-pdk
-
-require recipes-bsp/pa-lld/pa-lld.inc
-COMPATIBLE_MACHINE_append = "|c667x-evm"
-PR = "${INC_PR}.0"
-
-DEPENDS_append = " rm-lld-rtos"
-
-# HTML doc link params
-PDK_COMP_LINK_TEXT = "PA LLD"
diff --git a/recipes-bsp/pa-lld/pa-lld-test_git.bb b/recipes-bsp/pa-lld/pa-lld-test_git.bb
deleted file mode 100644
index 62ec1222..00000000
--- a/recipes-bsp/pa-lld/pa-lld-test_git.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-DESCRIPTION = "TI PA LLD unit test and example binaries"
-
-DEPENDS = "common-csl-ip pa-lld cppi-lld qmss-lld sa-lld"
-
-include pa-lld.inc
-
-PR = "${INC_PR}.1"
-
-CHOICELIST = "yes no"
-
-do_compile () {
-# Now build the lld unit test examples
- for device in ${DEVICELIST}
- do
- make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" PA_SRC_DIR=${S}
- for choice in ${CHOICELIST}
- do
- make -f makefile_armv7 tests examples PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" PA_SRC_DIR=${S} USEDYNAMIC_LIB="$choice"
- done
- done
-}
-
-do_install () {
- for device in ${DEVICELIST}
- do
- make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" PA_SRC_DIR=${S} INSTALL_BIN_BASE_DIR=${D}${bindir}
- done
-}
diff --git a/recipes-bsp/pa-lld/pa-lld.inc b/recipes-bsp/pa-lld/pa-lld.inc
deleted file mode 100644
index 83c57e31..00000000
--- a/recipes-bsp/pa-lld/pa-lld.inc
+++ /dev/null
@@ -1,24 +0,0 @@
-LICENSE = "BSD-3-Clause & TI-TFL"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/pa/COPYING.txt;md5=cd04fb087063a2a82c4ce61983836871"
-
-COMPATIBLE_MACHINE = "keystone"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-inherit ti-pdk-fetch
-
-TI_PDK_COMP = "ti.drv.pa"
-
-PE = "1"
-
-INC_PR = "r0"
-
-
-DEVICELIST = "k2h k2k k2l k2e"
-DEVICELIST_k2hk = "k2h k2k"
-DEVICELIST_k2l = "k2l"
-DEVICELIST_k2e = "k2e"
-
-LIBPA = "libpa"
-LIBPA_k2hk = "libpa"
-LIBPA_k2e = "libpa2"
-LIBPA_k2l = "libpa2"
diff --git a/recipes-bsp/pa-lld/pa-lld_git.bb b/recipes-bsp/pa-lld/pa-lld_git.bb
deleted file mode 100644
index f636ce4a..00000000
--- a/recipes-bsp/pa-lld/pa-lld_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "TI PA LLD library"
-
-DEPENDS = "common-csl-ip rm-lld"
-
-include pa-lld.inc
-
-PR = "${INC_PR}.1"
-
-do_compile () {
-# Now build the lld in the updated directory
- for device in ${DEVICELIST}
- do
- make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device"
- done
-}
-
-do_install () {
- make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
- chown -R root:root ${D}
-
-# Set the generic device library symbolic link
- ln -sf ${LIBPA}.so.1.0.0 ${D}${libdir}/libpa_device.so.1
- ln -sf libpa_device.so.1 ${D}${libdir}/libpa_device.so
-}