aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/osal
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/osal')
-rw-r--r--recipes-bsp/osal/osal-rtos_git.bb18
-rw-r--r--recipes-bsp/osal/osal-test_git.bb20
-rw-r--r--recipes-bsp/osal/osal.inc15
-rw-r--r--recipes-bsp/osal/osal_git.bb21
4 files changed, 0 insertions, 74 deletions
diff --git a/recipes-bsp/osal/osal-rtos_git.bb b/recipes-bsp/osal/osal-rtos_git.bb
deleted file mode 100644
index a718f7ca..00000000
--- a/recipes-bsp/osal/osal-rtos_git.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-inherit ti-pdk
-require recipes-bsp/osal/osal.inc
-
-PR = "${INC_PR}.0"
-
-COMPATIBLE_MACHINE_append = "|c66x|k3"
-
-DEPENDS_append_ti33x = " starterware-rtos"
-DEPENDS_append_ti43x = " starterware-rtos"
-
-# Build with make instead of XDC
-TI_PDK_XDCMAKE = "0"
-
-export PDK_OSAL_ROOT_PATH ="${WORKDIR}/build"
-export DEST_ROOT="${S}"
-
-# HTML doc link params
-PDK_COMP_LINK_TEXT = "OSAL Library"
diff --git a/recipes-bsp/osal/osal-test_git.bb b/recipes-bsp/osal/osal-test_git.bb
deleted file mode 100644
index 354aa797..00000000
--- a/recipes-bsp/osal/osal-test_git.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-DESCRIPTION = "TI OSAL tests"
-
-DEPENDS="common-csl-ip osal"
-
-include osal.inc
-
-PR = "${INC_PR}.1"
-
-EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} OSAL_SRC_DIR=${S}"
-
-do_compile () {
-# Build the tests
- oe_runmake clean
- oe_runmake tests
-}
-
-do_install () {
-# Install the binary
- oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir}
-}
diff --git a/recipes-bsp/osal/osal.inc b/recipes-bsp/osal/osal.inc
deleted file mode 100644
index e2143e13..00000000
--- a/recipes-bsp/osal/osal.inc
+++ /dev/null
@@ -1,15 +0,0 @@
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://osal.h;beginline=1;endline=31;md5=6fbde6922f8bca1e6cd371d3c2faa4f9"
-
-COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-inherit ti-pdk-fetch
-
-TI_PDK_COMP = "ti.osal"
-
-PE = "1"
-
-INC_PR = "r0"
-
-INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/libosal.a"
diff --git a/recipes-bsp/osal/osal_git.bb b/recipes-bsp/osal/osal_git.bb
deleted file mode 100644
index 4f881d2e..00000000
--- a/recipes-bsp/osal/osal_git.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-DESCRIPTION = "TI OSAL library for Linux"
-
-DEPENDS="common-csl-ip"
-
-include osal.inc
-
-PR = "${INC_PR}.1"
-
-EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
-
-do_compile () {
-# Build the lib
- oe_runmake clean
- oe_runmake lib
-}
-
-do_install () {
-# Install the lib
- oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
- chown -R root:root ${D}
-}