aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/osal
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/osal')
-rw-r--r--recipes-bsp/osal/osal-rtos_git.bb20
-rw-r--r--recipes-bsp/osal/osal-test_git.bb22
-rw-r--r--recipes-bsp/osal/osal.inc20
-rw-r--r--recipes-bsp/osal/osal_git.bb22
4 files changed, 0 insertions, 84 deletions
diff --git a/recipes-bsp/osal/osal-rtos_git.bb b/recipes-bsp/osal/osal-rtos_git.bb
deleted file mode 100644
index 62d1f997..00000000
--- a/recipes-bsp/osal/osal-rtos_git.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-inherit ti-pdk
-require recipes-bsp/osal/osal.inc
-
-PR = "${INC_PR}.0"
-
-COMPATIBLE_MACHINE_append = "|c66x|k3"
-
-S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}"
-
-DEPENDS_append_ti33x = " starterware-rtos"
-DEPENDS_append_ti43x = " starterware-rtos"
-
-# Build with make instead of XDC
-TI_PDK_XDCMAKE = "0"
-
-export PDK_OSAL_ROOT_PATH ="${WORKDIR}/build"
-export DEST_ROOT="${S}"
-
-# HTML doc link params
-PDK_COMP_LINK_TEXT = "OSAL Library"
diff --git a/recipes-bsp/osal/osal-test_git.bb b/recipes-bsp/osal/osal-test_git.bb
deleted file mode 100644
index 58156e3b..00000000
--- a/recipes-bsp/osal/osal-test_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "TI OSAL tests"
-
-DEPENDS="common-csl-ip osal"
-
-include osal.inc
-
-PR = "${INC_PR}.1"
-
-S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}"
-
-EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} OSAL_SRC_DIR=${S}"
-
-do_compile () {
-# Build the tests
- oe_runmake clean
- oe_runmake tests
-}
-
-do_install () {
-# Install the binary
- oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir}
-}
diff --git a/recipes-bsp/osal/osal.inc b/recipes-bsp/osal/osal.inc
deleted file mode 100644
index 5b38d7b2..00000000
--- a/recipes-bsp/osal/osal.inc
+++ /dev/null
@@ -1,20 +0,0 @@
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://osal.h;beginline=1;endline=31;md5=6fbde6922f8bca1e6cd371d3c2faa4f9"
-
-COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-OSAL_GIT_URI = "git://git.ti.com/keystone-rtos/osal.git"
-OSAL_GIT_PROTOCOL = "git"
-OSAL_GIT_BRANCH = "master"
-OSAL_GIT_DESTSUFFIX = "git/ti/osal"
-
-# Below commit ID corresponding to "DEV.OSAL.01.00.00.12"
-OSAL_SRCREV = "f9f47ad458a39201d822aa7f7e4774eb145ed451"
-
-BRANCH = "${OSAL_GIT_BRANCH}"
-SRC_URI = "${OSAL_GIT_URI};destsuffix=${OSAL_GIT_DESTSUFFIX};protocol=${OSAL_GIT_PROTOCOL};branch=${BRANCH}"
-
-SRCREV = "${OSAL_SRCREV}"
-PV = "01.00.00.12"
-INC_PR = "r1"
diff --git a/recipes-bsp/osal/osal_git.bb b/recipes-bsp/osal/osal_git.bb
deleted file mode 100644
index bb30ab5a..00000000
--- a/recipes-bsp/osal/osal_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "TI OSAL library for Linux"
-
-DEPENDS="common-csl-ip"
-
-include osal.inc
-
-PR = "${INC_PR}.1"
-
-S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}"
-
-EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
-
-do_compile () {
-# Build the lib
- oe_runmake clean
- oe_runmake lib
-}
-
-do_install () {
-# Install the lib
- oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
-}