aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-ti/devtools/ti-cgt-arm_18.12.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-extras/recipes-ti/devtools/ti-cgt-arm_18.12.5.bb')
-rw-r--r--meta-ti-extras/recipes-ti/devtools/ti-cgt-arm_18.12.5.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-ti/devtools/ti-cgt-arm_18.12.5.bb b/meta-ti-extras/recipes-ti/devtools/ti-cgt-arm_18.12.5.bb
new file mode 100644
index 00000000..b7b6d9b1
--- /dev/null
+++ b/meta-ti-extras/recipes-ti/devtools/ti-cgt-arm_18.12.5.bb
@@ -0,0 +1,44 @@
+SUMMARY = "TI ARM Code Generation Tools"
+HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
+LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Patrick-Powell & AFL-3.0 & MIT & BSD-2-Clause & PD & BSD-4-Clause"
+
+LIC_FILES_CHKSUM = "file://ti-cgt-arm_${PV}.LTS/README.txt;md5=79631eb21b2e5b7190cd3ff1dfd41108"
+
+require recipes-ti/includes/ti-unpack.inc
+require recipes-ti/includes/ti-staging.inc
+require recipes-ti/includes/ti-paths.inc
+
+S = "${WORKDIR}/ti-cgt-arm-${PV}"
+
+PE = "1"
+PR = "r0"
+
+SRC_URI = "http://software-dl.ti.com/codegen/esd/cgt_public_sw/TMS470/${PV}.LTS/${BINFILE};name=${BINFILE_NAME}"
+
+BINFILE = "ti_cgt_tms470_${PV}.LTS_linux_installer_x86.bin"
+TI_BIN_UNPK_ARGS = "--prefix ${S}"
+TI_BIN_UNPK_CMDS = ""
+
+# only x86_64 is supported
+COMPATIBLE_HOST = "x86_64.*-linux"
+COMPATIBLE_HOST:class-target = "null"
+
+do_install() {
+ install -d ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
+ cp -r ${S}/ti-cgt-arm*/. ${D}${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}
+}
+
+SRC_URI[cgt_arm_installer.md5sum] = "e9e668332cf86c965b4da9d1d488426b"
+SRC_URI[cgt_arm_installer.sha256sum] = "da976143128c619a278cb4214a4295c409d100f9e65ad2f4d0d1039db7cf98f4"
+
+BINFILE_NAME = "cgt_arm_installer"
+
+FILES:${PN} += "${M4_TOOLCHAIN_INSTALL_DIR_RECIPE}"
+
+INHIBIT_PACKAGE_STRIP = "1"
+INHIBIT_SYSROOT_STRIP = "1"
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+INSANE_SKIP:${PN} += "arch staticdev file-rdeps"
+
+BBCLASSEXTEND = "native nativesdk"