aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-ti/beagleboard/beaglebone-getting-started.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-extras/recipes-ti/beagleboard/beaglebone-getting-started.bb')
-rw-r--r--meta-ti-extras/recipes-ti/beagleboard/beaglebone-getting-started.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-ti/beagleboard/beaglebone-getting-started.bb b/meta-ti-extras/recipes-ti/beagleboard/beaglebone-getting-started.bb
new file mode 100644
index 00000000..85ab861d
--- /dev/null
+++ b/meta-ti-extras/recipes-ti/beagleboard/beaglebone-getting-started.bb
@@ -0,0 +1,21 @@
+SUMMARY = "BeagleBone Getting Started Guide"
+
+PR = "r22"
+
+inherit allarch
+
+LICENSE = "CC-BY-SA-3.0 & GPL-3.0-or-later & MIT & PD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f6f02761e31334c48f7021fb94c89aaa"
+
+SRCREV = "05bedba192646152b7bc80b0accaea75aef864e5"
+SRC_URI = "git://github.com/jadonk/beaglebone-getting-started.git;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${datadir}/${PN}
+ cp -R --no-dereference --preserve=mode,links ${S}/* ${D}${datadir}/${PN}
+}
+
+FILES:${PN} += "${datadir}/${PN}"
+INSANE_SKIP:${PN} = "file-rdeps"