aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ti-extras/recipes-ti/beagleboard/beaglebone-capes.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-extras/recipes-ti/beagleboard/beaglebone-capes.bb')
-rw-r--r--meta-ti-extras/recipes-ti/beagleboard/beaglebone-capes.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-ti/beagleboard/beaglebone-capes.bb b/meta-ti-extras/recipes-ti/beagleboard/beaglebone-capes.bb
new file mode 100644
index 00000000..ceefe0d6
--- /dev/null
+++ b/meta-ti-extras/recipes-ti/beagleboard/beaglebone-capes.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Userspace setup for beaglebone capes"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+PR = "r4"
+
+inherit allarch
+
+SRC_URI = "file://cape.service \
+ file://cape.sh \
+ file://cape-stop.sh \
+ "
+
+do_install() {
+ install -d ${D}${base_libdir}/systemd/system/
+ install -m 0644 ${WORKDIR}/cape.service ${D}${base_libdir}/systemd/system
+
+ install -d ${D}${base_libdir}/systemd/system/basic.target.wants
+ ln -sf ../cape.service ${D}${base_libdir}/systemd/system/basic.target.wants/
+
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/cape*.sh ${D}${bindir}
+}
+
+FILES:${PN} += "${base_libdir}/systemd/system"