aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb')
-rw-r--r--meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
new file mode 100644
index 00000000..3b06de9c
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb
@@ -0,0 +1,30 @@
+SUMMARY = "PRU HSR firmware"
+
+require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
+
+PE = "1"
+PR = "${INC_PR}.0"
+
+COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx|am65xx|am64xx"
+
+TARGET = " \
+ am335x-pru0-pruhsr-fw.elf \
+ am335x-pru1-pruhsr-fw.elf \
+ am437x-pru0-pruhsr-fw.elf \
+ am437x-pru1-pruhsr-fw.elf \
+ am57xx-pru0-pruhsr-fw.elf \
+ am57xx-pru1-pruhsr-fw.elf \
+ am65x-sr2-pru0-pruhsr-fw.elf \
+ am65x-sr2-pru1-pruhsr-fw.elf \
+ am65x-sr2-rtu0-pruhsr-fw.elf \
+ am65x-sr2-rtu1-pruhsr-fw.elf \
+ am65x-sr2-txpru0-pruhsr-fw.elf \
+ am65x-sr2-txpru1-pruhsr-fw.elf \
+"
+
+do_install() {
+ install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
+ for f in ${TARGET}; do
+ install -m 0644 ${S}/ti-pruss/$f ${D}${nonarch_base_libdir}/firmware/ti-pruss/$f
+ done
+}