aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ti-bsp/conf/layer.conf')
-rw-r--r--meta-ti-bsp/conf/layer.conf34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-ti-bsp/conf/layer.conf b/meta-ti-bsp/conf/layer.conf
new file mode 100644
index 00000000..03cbd7ea
--- /dev/null
+++ b/meta-ti-bsp/conf/layer.conf
@@ -0,0 +1,34 @@
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+METATIBASE := '${@os.path.normpath("${LAYERDIR}/")}'
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "meta-ti-bsp"
+BBFILE_PATTERN_meta-ti-bsp := "^${LAYERDIR}/"
+BBFILE_PRIORITY_meta-ti-bsp = "6"
+
+LAYERSERIES_COMPAT_meta-ti-bsp = "nanbield scarthgap styhead"
+
+LICENSE_PATH += "${LAYERDIR}/licenses"
+
+LAYERDEPENDS_meta-ti-bsp = " \
+ core \
+ meta-arm \
+"
+
+BBFILES_DYNAMIC += " \
+ clang-layer:${LAYERDIR}/dynamic-layers/clang-layer/recipes*/*/*.bbappend \
+"
+
+SIGGEN_EXCLUDERECIPES_ABISAFE += " \
+ mesa-pvr \
+"
+
+HOSTTOOLS_NONFATAL += "truncate xxd comm"
+
+TI_COMMON_DEPLOY ?= "${TOPDIR}/deploy-ti"
+DEPLOY_DIR_IMAGE:ti-soc = "${TI_COMMON_DEPLOY}/images/${MACHINE}"
+SDK_DEPLOY:ti-soc = "${TI_COMMON_DEPLOY}/sdk"
+PSEUDO_IGNORE_PATHS:append:ti-soc = ",${TI_COMMON_DEPLOY}"