aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-security/selinux/libsepol_3.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/selinux/libsepol_3.6.bb')
-rw-r--r--recipes-security/selinux/libsepol_3.6.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-security/selinux/libsepol_3.6.bb b/recipes-security/selinux/libsepol_3.6.bb
new file mode 100644
index 0000000..0c28e9b
--- /dev/null
+++ b/recipes-security/selinux/libsepol_3.6.bb
@@ -0,0 +1,18 @@
+SUMMARY = "SELinux binary policy manipulation library"
+DESCRIPTION = "libsepol provides an API for the manipulation of SELinux binary policies. \
+It is used by checkpolicy (the policy compiler) and similar tools, as well \
+as by programs like load_policy that need to perform specific transformations \
+on binary policies such as customizing policy boolean settings."
+SECTION = "base"
+LICENSE = "LGPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
+
+require selinux_common.inc
+
+inherit lib_package
+
+S = "${WORKDIR}/git/libsepol"
+
+DEPENDS = "flex-native"
+
+BBCLASSEXTEND = "native"