aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-security/selinux/libselinux_3.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-security/selinux/libselinux_3.6.bb')
-rw-r--r--recipes-security/selinux/libselinux_3.6.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-security/selinux/libselinux_3.6.bb b/recipes-security/selinux/libselinux_3.6.bb
new file mode 100644
index 0000000..b0dcde6
--- /dev/null
+++ b/recipes-security/selinux/libselinux_3.6.bb
@@ -0,0 +1,33 @@
+SUMMARY = "SELinux library and simple utilities"
+DESCRIPTION = "libselinux provides an API for SELinux applications to get and set \
+process and file security contexts and to obtain security policy \
+decisions. Required for any applications that use the SELinux API."
+SECTION = "base"
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=84b4d2c6ef954a2d4081e775a270d0d0"
+
+require selinux_common.inc
+
+inherit lib_package pkgconfig
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/libselinux:"
+SRC_URI += "\
+ file://0003-libselinux-restore-drop-the-obsolete-LSF-transitiona.patch \
+ "
+
+S = "${WORKDIR}/git/libselinux"
+
+DEPENDS = "libsepol libpcre2"
+DEPENDS:append:libc-musl = " fts"
+
+def get_policyconfigarch(d):
+ import re
+ target = d.getVar('TARGET_ARCH')
+ p = re.compile('i.86')
+ target = p.sub('i386',target)
+ return "ARCH=%s" % (target)
+
+EXTRA_OEMAKE = "${@get_policyconfigarch(d)}"
+EXTRA_OEMAKE:append:libc-musl = " FTS_LDLIBS=-lfts"
+
+BBCLASSEXTEND = "native"