aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux_4.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux_4.7.bb')
-rw-r--r--recipes-kernel/linux/linux_4.7.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux_4.7.bb b/recipes-kernel/linux/linux_4.7.bb
new file mode 100644
index 0000000..bf670b8
--- /dev/null
+++ b/recipes-kernel/linux/linux_4.7.bb
@@ -0,0 +1,19 @@
+# Copyright (C) 2015 Romain Perier
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require recipes-kernel/linux/linux-yocto.inc
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git;branch=linux-4.7.y"
+
+SRCREV = "${AUTOREV}"
+LINUX_VERSION = "4.7"
+# Override local version in order to use the one generated by linux build system
+# And not "yocto-standard"
+LINUX_VERSION_EXTENSION = ""
+PR = "r1"
+PV = "${LINUX_VERSION}"
+
+# Include only supported boards for now
+COMPATIBLE_MACHINE = "(radxarock|marsboard-rk3066|firefly-rk3288)"
+KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${@d.getVar('KERNEL_DEFCONFIG', True) or ""}"
+deltask kernel_configme