aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/images/petitboot-initramfs-image.bb19
-rw-r--r--recipes-core/images/rockchip-basic-image.bb12
-rw-r--r--recipes-core/initrdscripts/files/init-boot-petitboot.sh18
-rw-r--r--recipes-core/initrdscripts/initramfs-boot-petitboot_1.0.bb19
4 files changed, 0 insertions, 68 deletions
diff --git a/recipes-core/images/petitboot-initramfs-image.bb b/recipes-core/images/petitboot-initramfs-image.bb
deleted file mode 100644
index 5124fb7..0000000
--- a/recipes-core/images/petitboot-initramfs-image.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright (C) 2015 Romain Perier <romain.perier@gmail.com>
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-PACKAGE_INSTALL = "initramfs-boot-petitboot busybox base-files petitboot ${ROOTFS_BOOTSTRAP_INSTALL}"
-
-# Do not pollute the initrd image with rootfs features
-IMAGE_FEATURES = ""
-
-export IMAGE_BASENAME = "petitboot-initramfs-image"
-IMAGE_LINGUAS = ""
-
-LICENSE = "MIT"
-IMAGE_FSTYPES = "cpio.xz"
-
-inherit core-image
-
-IMAGE_ROOTFS_SIZE = "8192"
-
-BAD_RECOMMENDATIONS += "busybox-syslog"
diff --git a/recipes-core/images/rockchip-basic-image.bb b/recipes-core/images/rockchip-basic-image.bb
deleted file mode 100644
index 25fb30e..0000000
--- a/recipes-core/images/rockchip-basic-image.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-# Copyright (C) 2014 Romain Perier <romain.perier@gmail.com>
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-include recipes-core/images/core-image-minimal.bb
-
-DESCRIPTION = "Basic image for Rockchip devices. This is a small image just \
-capable of allowing a device to boot with packages management, \
-ssh server and development tools."
-IMAGE_FEATURES_append = " package-management ssh-server-dropbear"
-IMAGE_INSTALL_append = " net-kexec "
-
-LICENSE = "MIT"
diff --git a/recipes-core/initrdscripts/files/init-boot-petitboot.sh b/recipes-core/initrdscripts/files/init-boot-petitboot.sh
deleted file mode 100644
index aa18f72..0000000
--- a/recipes-core/initrdscripts/files/init-boot-petitboot.sh
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-# Copyright (C) 2015 Romain Perier <romain.perier@gmail.com>
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-PATH=/sbin:/bin:/usr/sbin:/usr/bin
-
-mount -t proc proc /proc
-mount -t sysfs sysfs /sys
-mount -t devtmpfs dev /dev
-mkdir /var/volatile/log /var/volatile/tmp
-/lib/udev/udevd --daemon
-pb-discover --verbose -l /var/log/pb-discover.log &
-udevadm trigger --action=add
-udevadm settle
-
-clear
-export TERM=screen
-petitboot-nc
diff --git a/recipes-core/initrdscripts/initramfs-boot-petitboot_1.0.bb b/recipes-core/initrdscripts/initramfs-boot-petitboot_1.0.bb
deleted file mode 100644
index a14e279..0000000
--- a/recipes-core/initrdscripts/initramfs-boot-petitboot_1.0.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright (C) 2015 Romain Perier <romain.perier@gmail.com>
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-inherit allarch
-
-SUMMARY = "Extremely basic init script which starts Petitboot"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-SRC_URI = "file://init-boot-petitboot.sh"
-
-do_install() {
- install -d ${D}/dev
- mknod -m 600 ${D}/dev/console c 5 1
- mknod -m 666 ${D}/dev/null c 1 3
- install -m 0755 ${WORKDIR}/init-boot-petitboot.sh ${D}/init
-}
-
-FILES_${PN} += " /init /dev/console /dev/null "
-