aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/rpi-gpio_0.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/rpi-gpio_0.7.1.bb')
-rw-r--r--recipes-devtools/python/rpi-gpio_0.7.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/rpi-gpio_0.7.1.bb b/recipes-devtools/python/rpi-gpio_0.7.1.bb
new file mode 100644
index 0000000..e7a9950
--- /dev/null
+++ b/recipes-devtools/python/rpi-gpio_0.7.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "A module to control Raspberry Pi GPIO channels"
+HOMEPAGE = "https://sourceforge.net/projects/raspberry-gpio-python/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=a2294b0b1daabc30dfb5b3de73b2e00a"
+
+PYPI_PACKAGE = "RPi.GPIO"
+
+inherit pypi setuptools3
+
+SRC_URI += "file://0001-Remove-nested-functions.patch \
+ "
+SRC_URI[sha256sum] = "cd61c4b03c37b62bba4a5acfea9862749c33c618e0295e7e90aa4713fb373b70"
+
+COMPATIBLE_MACHINE = "^rpi$"