aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.10.bb')
-rw-r--r--recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.10.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.10.bb b/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.10.bb
new file mode 100644
index 0000000..8ff3073
--- /dev/null
+++ b/recipes-devtools/python/python3-adafruit-circuitpython-register_1.9.10.bb
@@ -0,0 +1,14 @@
+SUMMARY = "CircuitPython data descriptor classes to represent hardware registers on I2C and SPI devices."
+HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_Register"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ec69d6e9e6c85adfb7799d7f8cf044e"
+
+SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_Register.git;branch=main;protocol=https"
+SRCREV = "d1e8ac7ad9dcd65ab83749db3e5c96ffee80ebb7"
+S = "${WORKDIR}/git"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += "python3-core"