aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt4
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt4')
-rw-r--r--recipes-qt4/images/core-image-lsb-qt4.bb2
-rw-r--r--recipes-qt4/packagegroups/packagegroup-core-qt.bb2
-rw-r--r--recipes-qt4/packagegroups/packagegroup-qt-toolchain-target.bb2
-rw-r--r--recipes-qt4/recipes-python/python-pyqt_4.12.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/recipes-qt4/images/core-image-lsb-qt4.bb b/recipes-qt4/images/core-image-lsb-qt4.bb
index 03d27f8..c5c8f2b 100644
--- a/recipes-qt4/images/core-image-lsb-qt4.bb
+++ b/recipes-qt4/images/core-image-lsb-qt4.bb
@@ -9,5 +9,5 @@ IMAGE_INSTALL = "\
inherit core-image
-inherit distro_features_check
+inherit features_check
REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/recipes-qt4/packagegroups/packagegroup-core-qt.bb b/recipes-qt4/packagegroups/packagegroup-core-qt.bb
index b7de69e..1989646 100644
--- a/recipes-qt4/packagegroups/packagegroup-core-qt.bb
+++ b/recipes-qt4/packagegroups/packagegroup-core-qt.bb
@@ -9,7 +9,7 @@ PR = "r4"
# Qt4 could NOT be built on MIPS64 with 64 bits userspace
COMPATIBLE_HOST_mips64 = "null"
-inherit packagegroup distro_features_check
+inherit packagegroup features_check
# The quicky and fotowall requires x11 in DISTRO_FEATURES
REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/recipes-qt4/packagegroups/packagegroup-qt-toolchain-target.bb b/recipes-qt4/packagegroups/packagegroup-qt-toolchain-target.bb
index 772c151..7e6f839 100644
--- a/recipes-qt4/packagegroups/packagegroup-qt-toolchain-target.bb
+++ b/recipes-qt4/packagegroups/packagegroup-qt-toolchain-target.bb
@@ -4,7 +4,7 @@ QTLIBPREFIX = ""
require packagegroup-qt-toolchain-target.inc
-inherit distro_features_check
+inherit features_check
# depends on qt4-x11-free
REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/recipes-qt4/recipes-python/python-pyqt_4.12.bb b/recipes-qt4/recipes-python/python-pyqt_4.12.bb
index bc51d5b..5ff8a61 100644
--- a/recipes-qt4/recipes-python/python-pyqt_4.12.bb
+++ b/recipes-qt4/recipes-python/python-pyqt_4.12.bb
@@ -18,7 +18,7 @@ S = "${WORKDIR}/PyQt4_gpl_x11-${PV}"
PARALLEL_MAKE = ""
-inherit qmake2 pythonnative python-dir distro_features_check
+inherit qmake2 pythonnative python-dir features_check
# depends on qt4-x11-free
REQUIRED_DISTRO_FEATURES = "x11"