aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-test/images/initramfs-test-full-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/images/initramfs-test-full-image.bb')
-rw-r--r--recipes-test/images/initramfs-test-full-image.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-test/images/initramfs-test-full-image.bb b/recipes-test/images/initramfs-test-full-image.bb
new file mode 100644
index 0000000..d3a5e97
--- /dev/null
+++ b/recipes-test/images/initramfs-test-full-image.bb
@@ -0,0 +1,46 @@
+require recipes-test/images/initramfs-test-image.bb
+
+DESCRIPTION = "Relatively larger ramdisk image for running tests (bootrr, etc)"
+
+PACKAGE_INSTALL += " \
+ bootrr \
+ coreutils \
+ hdparm \
+ kexec \
+ lsof \
+ ncurses \
+ ncurses-terminfo \
+ ncurses-terminfo-base \
+ stress-ng \
+ util-linux \
+ util-linux-chrt \
+ util-linux-lsblk \
+"
+
+PACKAGE_INSTALL:append:libc-glibc = " \
+ rt-tests \
+"
+
+# We'd like to include extra packages provided by layers which we do not depend
+# on. This can be handled by .bbappends, but then image recipes including this
+# one would not get all these tools. So simulate dynamic bbappend here.
+
+# ncurses-terminfo is provided by oe-core layer, but it's only needed for gps (cgps), so include it here
+PACKAGE_INSTALL_openembedded-layer += " \
+ crash \
+ dhrystone \
+ gpsd \
+ gpsd-machine-conf \
+ gps-utils \
+ iozone3 \
+ libgpiod \
+ libgpiod-tools \
+ lmbench \
+ makedumpfile \
+ mbw \
+ ncurses-terminfo-base \
+ sysbench \
+ tinymembench \
+ tiobench \
+ whetstone \
+"