aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-support/pd-mapper/pd-mapper_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/pd-mapper/pd-mapper_git.bb')
-rw-r--r--recipes-support/pd-mapper/pd-mapper_git.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/recipes-support/pd-mapper/pd-mapper_git.bb b/recipes-support/pd-mapper/pd-mapper_git.bb
index 9e5ca11..34dffe0 100644
--- a/recipes-support/pd-mapper/pd-mapper_git.bb
+++ b/recipes-support/pd-mapper/pd-mapper_git.bb
@@ -5,24 +5,21 @@ SECTION = "devel"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c5d4ab97bca4e843c5afdbf78aa5fdee"
-DEPENDS = "qrtr"
+DEPENDS = "qrtr xz"
inherit systemd
-SRCREV = "ab5074fdd5e4130578aa4c99b00d44527a79636f"
+SRCREV = "10997ba7c43a3787a40b6b1b161408033e716374"
SRC_URI = "git://github.com/andersson/${BPN}.git;branch=master;protocol=https \
- file://0001-pd-mapper-Include-limits.h-for-PATH_MAX.patch \
"
PV = "0.0+${SRCPV}"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "prefix=${prefix} bindir=${bindir} libdir=${libdir} includedir=${includedir} LDFLAGS='${LDFLAGS} -Wl,-lqrtr'"
-
do_install () {
oe_runmake install DESTDIR=${D} prefix=${prefix} servicedir=${systemd_unitdir}/system
}
-SYSTEMD_SERVICE_${PN} = "pd-mapper.service"
-RDEPENDS_${PN} += "qrtr"
+SYSTEMD_SERVICE:${PN} = "pd-mapper.service"
+RDEPENDS:${PN} += "qrtr"