aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-yocto_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-yocto_%.bbappend')
-rw-r--r--recipes-kernel/linux/linux-yocto_%.bbappend14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto_%.bbappend b/recipes-kernel/linux/linux-yocto_%.bbappend
new file mode 100644
index 0000000..8b4dc40
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -0,0 +1,14 @@
+# do not override KBRANCH and SRCREV_machine, use default ones.
+COMPATIBLE_MACHINE:qcom = "qcom-armv8a|qcom-armv7a"
+
+FILESEXTRAPATHS:prepend:qcom := "${THISDIR}/${PN}:"
+
+# include all Qualcomm-specific files
+SRC_URI:append:qcom = " \
+ file://qcom.scc \
+"
+
+# For boot.img
+QCOM_BOOTIMG = ""
+QCOM_BOOTIMG:qcom = "linux-qcom-bootimg"
+inherit ${QCOM_BOOTIMG}