aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa/mesa_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/mesa_git.bb')
-rw-r--r--recipes-graphics/mesa/mesa_git.bb32
1 files changed, 16 insertions, 16 deletions
diff --git a/recipes-graphics/mesa/mesa_git.bb b/recipes-graphics/mesa/mesa_git.bb
index 5940e8c..fda9950 100644
--- a/recipes-graphics/mesa/mesa_git.bb
+++ b/recipes-graphics/mesa/mesa_git.bb
@@ -1,34 +1,34 @@
require recipes-graphics/mesa/mesa.inc
-SRC_URI = "git://gitlab.freedesktop.org/mesa/mesa.git;protocol=https \
+SRC_URI = "git://gitlab.freedesktop.org/mesa/mesa.git;protocol=https;branch=main \
file://0001-meson.build-check-for-all-linux-host_os-combinations.patch \
file://0002-meson.build-make-TLS-ELF-optional.patch \
- file://0003-Allow-enable-DRI-without-DRI-drivers.patch \
- file://0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch \
file://0001-meson-misdetects-64bit-atomics-on-mips-clang.patch \
- file://fix-meson-config-compat.patch \
"
-LIC_FILES_CHKSUM = "file://docs/license.rst;md5=9aa1bc48c9826ad9fdb16661f6930496"
+LIC_FILES_CHKSUM = "file://docs/license.rst;md5=17a4ea65de7a9ab42437f3131e616a7f"
-SRCREV = "aed8d30b507568b7fc0f32afca012f8def5aca16"
-#SRCREV_sm8250 = "${AUTOREV}"
+SRCREV := "${@oe.utils.conditional("MESA_DEV", "1", "${AUTOREV}", "26677008b9a7c0ef82f2a7f4b479d3cb06097c66", d)}"
+DEFAULT_PREFERENCE = "${@oe.utils.conditional("MESA_DEV", "1", "1", "-1", d)}"
-PLATFORMS_remove = "drm surfaceless"
+PLATFORMS:remove = "drm surfaceless"
+PACKAGECONFIG[osmesa] = "-Dosmesa=true,-Dosmesa=false"
+DRIDRIVERS:remove = "swrast"
+DRIDRIVERS:append = ",auto"
+DRIDRIVERS:class-native = ",auto"
+DRIDRIVERS:class-nativesdk = ",auto"
S = "${WORKDIR}/git"
-PV = "20.4-dev+git${SRCPV}"
-
-# Do not select this version by default
-DEFAULT_PREFERENCE = "-1"
+PV = "2x.x-dev+git${SRCPV}"
+ERROR_QA:remove = "version-going-backwards"
# Add package to install require files to run tests for mesa
PACKAGES =+ "mesa-ci"
-FILES_${PN}-ci = "${bindir}/deqp-runner.sh ${datadir}/mesa/deqp-*"
-do_install_append () {
+FILES:${PN}-ci = "${bindir}/deqp-runner.sh ${datadir}/mesa/deqp-*"
+do_install:append () {
install -d ${D}/${datadir}/mesa
- install -m 0644 ${S}/.gitlab-ci/deqp-default-skips.txt ${D}/${datadir}/mesa/
- for f in ${S}/.gitlab-ci/deqp-freedreno-*; do
+ install -m 0644 ${S}/.gitlab-ci/all-skips.txt ${D}/${datadir}/mesa/
+ for f in ${S}/src/freedreno/ci/deqp-freedreno-*; do
install -m 0644 $f ${D}/${datadir}/mesa/
done