aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa/mesa_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/mesa_%.bbappend')
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend11
1 files changed, 4 insertions, 7 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index c5794f4..3f4a6e2 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,13 +1,10 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
# Enable freedreno driver
PACKAGECONFIG_FREEDRENO = "\
freedreno \
- ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xa', '', d)} \
+ tools \
+ ${@bb.utils.contains('BBFILE_COLLECTIONS', 'openembedded-layer', 'freedreno-fdperf', '', d)} \
"
-PACKAGECONFIG_append_apq8016 = "${PACKAGECONFIG_FREEDRENO}"
-PACKAGECONFIG_append_apq8064 = "${PACKAGECONFIG_FREEDRENO}"
-PACKAGECONFIG_append_apq8096 = "${PACKAGECONFIG_FREEDRENO}"
-PACKAGECONFIG_append_sdm845 = "${PACKAGECONFIG_FREEDRENO}"
-PACKAGECONFIG_append_sm8250 = "${PACKAGECONFIG_FREEDRENO}"
+PACKAGECONFIG:append:qcom = "${PACKAGECONFIG_FREEDRENO}"