aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch')
-rw-r--r--recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch16
1 files changed, 7 insertions, 9 deletions
diff --git a/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch b/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
index 2a78921..dc89ffc 100644
--- a/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
+++ b/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
@@ -1,4 +1,4 @@
-From 08c1591085f88190884809aeaf562d5a963399f7 Mon Sep 17 00:00:00 2001
+From fdcbfd2841eb34f44bdf51aeb4ef45811b66fd75 Mon Sep 17 00:00:00 2001
From: Alistair Francis <alistair@alistair23.me>
Date: Thu, 14 Nov 2019 13:04:49 -0800
Subject: [PATCH] meson.build: check for all linux host_os combinations
@@ -14,15 +14,16 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Alistair Francis <alistair@alistair23.me>
+
---
meson.build | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/meson.build b/meson.build
-index be007953c8b..e3e1dbfb116 100644
+index ff333961a0d..5931260dd3d 100644
--- a/meson.build
+++ b/meson.build
-@@ -152,7 +152,7 @@ with_any_opengl = with_opengl or with_gles1 or with_gles2
+@@ -158,7 +158,7 @@ with_any_opengl = with_opengl or with_gles1 or with_gles2
# Only build shared_glapi if at least one OpenGL API is enabled
with_shared_glapi = with_shared_glapi and with_any_opengl
@@ -31,15 +32,12 @@ index be007953c8b..e3e1dbfb116 100644
dri_drivers = get_option('dri-drivers')
if dri_drivers.contains('auto')
-@@ -928,7 +928,7 @@ if cc.compiles('__uint128_t foo(void) { return 0; }',
+@@ -1000,7 +1000,7 @@ if cc.compiles('__uint128_t foo(void) { return 0; }',
endif
# TODO: this is very incomplete
--if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd'].contains(host_machine.system())
-+if ['cygwin', 'gnu', 'gnu/kfreebsd'].contains(host_machine.system()) or host_machine.system().startswith('linux')
+-if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku'].contains(host_machine.system())
++if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku'].contains(host_machine.system()) or host_machine.system().startswith('linux')
pre_args += '-D_GNU_SOURCE'
elif host_machine.system() == 'sunos'
pre_args += '-D__EXTENSIONS__'
---
-2.28.0
-