aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware/firmware-qcom-ifc6410.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/firmware/firmware-qcom-ifc6410.bb')
-rw-r--r--recipes-bsp/firmware/firmware-qcom-ifc6410.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-bsp/firmware/firmware-qcom-ifc6410.bb b/recipes-bsp/firmware/firmware-qcom-ifc6410.bb
new file mode 100644
index 0000000..1fbeac2
--- /dev/null
+++ b/recipes-bsp/firmware/firmware-qcom-ifc6410.bb
@@ -0,0 +1,22 @@
+# Specify location of the corresponding NON-HLOS.bin file by adding
+# NHLOS_URI:pn-firmware-qcom-ifc6410 = "..." to local.conf. Use "file://"
+# if the file is provided locally.
+
+DESCRIPTION = "QCOM Firmware for Inforce IFC6410 board"
+
+LICENSE = "CLOSED"
+
+# ifc6410 firmware is unsigned, so install into generic location
+FW_QCOM_NAME = "apq8064"
+
+FW_QCOM_LIST = "dsps.mbn gss.mbn q6.mbn wcnss.mbn"
+
+require recipes-bsp/firmware/firmware-qcom.inc
+require recipes-bsp/firmware/firmware-qcom-nhlos.inc
+
+SPLIT_FIRMWARE_PACKAGES = " \
+ linux-firmware-qcom-${FW_QCOM_NAME}-dsps \
+ linux-firmware-qcom-${FW_QCOM_NAME}-gss \
+ linux-firmware-qcom-${FW_QCOM_NAME}-q6 \
+ linux-firmware-qcom-${FW_QCOM_NAME}-wifi \
+"