aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-nexus/firmware-qcom-nexus6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/firmware-nexus/firmware-qcom-nexus6.bb')
-rw-r--r--recipes-bsp/firmware-nexus/firmware-qcom-nexus6.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-bsp/firmware-nexus/firmware-qcom-nexus6.bb b/recipes-bsp/firmware-nexus/firmware-qcom-nexus6.bb
new file mode 100644
index 0000000..9d6df42
--- /dev/null
+++ b/recipes-bsp/firmware-nexus/firmware-qcom-nexus6.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "QCOM Firmware for Motorola Google Nexus 6"
+
+FW_QCOM_NAME = "shamu"
+FW_QCOM_SUBDIR = "apq8084/Motorola/${FW_QCOM_NAME}"
+AOSP_BUILD = "ngi77b"
+CHECKSUM_qcom = "b5a5aacc"
+
+SRC_URI[qcom.sha256sum] = "811ccc3c8bd4b832a26fc36aac5a46af7000d849c7217032e1d0819bfb2000dc"
+
+RDEPENDS:${PN} += "linux-firmware-qcom-adreno-a4xx"
+
+require recipes-bsp/firmware-nexus/firmware-qcom-nexus.inc
+
+do_install:append() {
+ install -d ${D}${FW_QCOM_PATH}
+
+ install -m 0644 adsp.mbn ${D}${FW_QCOM_PATH}
+ install -m 0644 venus.mbn ${D}${FW_QCOM_PATH}
+}