aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-nexus/firmware-qcom-nexus4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/firmware-nexus/firmware-qcom-nexus4.bb')
-rw-r--r--recipes-bsp/firmware-nexus/firmware-qcom-nexus4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/firmware-nexus/firmware-qcom-nexus4.bb b/recipes-bsp/firmware-nexus/firmware-qcom-nexus4.bb
new file mode 100644
index 0000000..58e7e3f
--- /dev/null
+++ b/recipes-bsp/firmware-nexus/firmware-qcom-nexus4.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "QCOM Firmware for LGE Google Nexus 4"
+
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://license.txt;md5=0d238870f50c84250a14191d17aaf1d5"
+
+FW_QCOM_NAME = "mako"
+FW_QCOM_SUBDIR = "apq8064/LGE/${FW_QCOM_NAME}"
+AOSP_BUILD = "lmy48t"
+CHECKSUM_qcom = "8c489b7e"
+
+SRC_URI[qcom.sha256sum] = "d87a4e4958c5750818fd525c32c7b6a659cd8da7e0dd46d92c16ad8c5aa1bf68"
+
+require recipes-bsp/firmware-nexus/firmware-qcom-nexus.inc
+
+SRC_URI += "git://android.googlesource.com/device/lge/${FW_QCOM_NAME};protocol=https;branch=master;name=aosp"
+SRCREV_aosp = "33f0114334f9304dd69a8dfac24bc7f3d195d3be"
+PV:append = "+git${SRCPV}"
+
+RDEPENDS:${PN} += "linux-firmware-qcom-adreno-a3xx"
+
+do_install:append() {
+ install -d ${D}${FW_QCOM_PATH}
+
+ install -m 0644 dsps.mbn ${D}${FW_QCOM_PATH}
+ install -m 0644 q6.mbn ${D}${FW_QCOM_PATH}
+ install -m 0644 vidc.mbn ${D}${FW_QCOM_PATH}
+ install -m 0644 wcnss.mbn ${D}${FW_QCOM_PATH}
+
+ install -m 0644 vendor/qcom/${FW_QCOM_NAME}/proprietary/vidc_1080p.fw ${D}${FW_QCOM_PATH}
+
+ install -m 0644 ${WORKDIR}/git/WCNSS_cfg.dat ${D}${FW_QCOM_PATH}
+ install -m 0644 ${WORKDIR}/git/WCNSS_qcom_wlan_nv.bin ${D}${FW_QCOM_PATH}
+}