aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-mono
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-mono')
-rw-r--r--recipes-mono/images/core-image-mono.inc2
-rw-r--r--recipes-mono/mono/mono-5.2.0.175.inc6
-rw-r--r--recipes-mono/mono/mono-native_5.2.0.175.bb4
-rw-r--r--recipes-mono/mono/mono_5.2.0.175.bb7
-rw-r--r--recipes-mono/nuget/nuget.inc41
-rw-r--r--recipes-mono/nuget/nuget/nuget.sh.in3
-rw-r--r--recipes-mono/nuget/nuget_3.5.0.bb4
-rw-r--r--recipes-mono/nuget/nuget_4.1.0.bb4
8 files changed, 70 insertions, 1 deletions
diff --git a/recipes-mono/images/core-image-mono.inc b/recipes-mono/images/core-image-mono.inc
index 8e38de3..83f630b 100644
--- a/recipes-mono/images/core-image-mono.inc
+++ b/recipes-mono/images/core-image-mono.inc
@@ -1,2 +1,2 @@
-IMAGE_INSTALL += "mono mono-helloworld tzdata"
+IMAGE_INSTALL += "mono mono-helloworld nuget tzdata"
diff --git a/recipes-mono/mono/mono-5.2.0.175.inc b/recipes-mono/mono/mono-5.2.0.175.inc
new file mode 100644
index 0000000..95bbe4a
--- /dev/null
+++ b/recipes-mono/mono/mono-5.2.0.175.inc
@@ -0,0 +1,6 @@
+SRC_URI[md5sum] = "825edd8e3154fc373900b360c156b85e"
+SRC_URI[sha256sum] = "cd00cc9d582449853b861419fa5647c0c2174e7fc07b2aeb03ba5ca847da4b18"
+
+S = "${WORKDIR}/mono-${PV}"
+
+EXTRA_OECONF = "--disable-btls"
diff --git a/recipes-mono/mono/mono-native_5.2.0.175.bb b/recipes-mono/mono/mono-native_5.2.0.175.bb
new file mode 100644
index 0000000..72fa593
--- /dev/null
+++ b/recipes-mono/mono/mono-native_5.2.0.175.bb
@@ -0,0 +1,4 @@
+require mono-5.xx.inc
+require mono-mit.inc
+require mono-native-5.xx-base.inc
+require mono-${PV}.inc
diff --git a/recipes-mono/mono/mono_5.2.0.175.bb b/recipes-mono/mono/mono_5.2.0.175.bb
new file mode 100644
index 0000000..82a7a78
--- /dev/null
+++ b/recipes-mono/mono/mono_5.2.0.175.bb
@@ -0,0 +1,7 @@
+require mono-5.xx.inc
+require mono-mit.inc
+require ${PN}-base.inc
+require mono-${PV}.inc
+
+PACKAGES += "${PN}-profiler "
+FILES_${PN}-profiler += " ${datadir}/mono-2.0/mono/profiler/*"
diff --git a/recipes-mono/nuget/nuget.inc b/recipes-mono/nuget/nuget.inc
new file mode 100644
index 0000000..cf3ed21
--- /dev/null
+++ b/recipes-mono/nuget/nuget.inc
@@ -0,0 +1,41 @@
+SUMMARY = "Package manager for .Net/Mono development platform"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://Apache-LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+HOMEPAGE = "http://nuget.org/"
+
+# This package ships Mono EXE and a shell script
+PACKAGE_ARCH="all"
+
+inherit mono
+
+SRC_URI = " \
+ http://dist.nuget.org/win-x86-commandline/v${PV}/nuget.exe;downloadfilename=NuGet-v${PV}.exe \
+ http://www.apache.org/licenses/LICENSE-2.0.txt;downloadfilename=Apache-LICENSE-2.0.txt;name=lic \
+ file://nuget.sh.in \
+ "
+
+SRC_URI[lic.md5sum] = "3b83ef96387f14655fc854ddc3c6bd57"
+SRC_URI[lic.sha256sum] = "cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30"
+
+S = "${WORKDIR}"
+
+do_install () {
+ install -d -m0755 ${D}${bindir}
+ install -m0755 ${WORKDIR}/nuget.sh.in ${D}${bindir}/nuget
+ sed -i -e 's:@bindir@:${bindir}:g' -e 's:@libdir@:${libdir}:g' ${D}${bindir}/nuget
+
+ install -d -m0755 ${D}${libdir}/mono/nuget
+ install -m0755 ${WORKDIR}/NuGet-v${PV}.exe ${D}${libdir}/mono/nuget/NuGet.exe
+}
+
+FILES_${PN} += "${libdir}/mono/nuget"
+
+SYSROOT_PREPROCESS_FUNCS += "nuget_sysroot_preprocess"
+
+nuget_sysroot_preprocess () {
+ install -d -m0755 ${SYSROOT_DESTDIR}${bindir_crossscripts}/
+ install -m0755 ${WORKDIR}/nuget.sh.in ${SYSROOT_DESTDIR}${bindir_crossscripts}/nuget
+ sed -i -e 's:@bindir@:${STAGING_BINDIR_NATIVE}:g' -e 's:@libdir@:${STAGING_LIBDIR}:g' ${SYSROOT_DESTDIR}${bindir_crossscripts}/nuget
+}
+
+DIRFILES = "1"
diff --git a/recipes-mono/nuget/nuget/nuget.sh.in b/recipes-mono/nuget/nuget/nuget.sh.in
new file mode 100644
index 0000000..4e4dc1e
--- /dev/null
+++ b/recipes-mono/nuget/nuget/nuget.sh.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec @bindir@/mono @libdir@/mono/nuget/NuGet.exe "$@"
diff --git a/recipes-mono/nuget/nuget_3.5.0.bb b/recipes-mono/nuget/nuget_3.5.0.bb
new file mode 100644
index 0000000..4b743e9
--- /dev/null
+++ b/recipes-mono/nuget/nuget_3.5.0.bb
@@ -0,0 +1,4 @@
+require nuget.inc
+
+SRC_URI[md5sum] = "406324e1744923a530a3f45b8e4fe1eb"
+SRC_URI[sha256sum] = "399ec24c26ed54d6887cde61994bb3d1cada7956c1b19ff880f06f060c039918"
diff --git a/recipes-mono/nuget/nuget_4.1.0.bb b/recipes-mono/nuget/nuget_4.1.0.bb
new file mode 100644
index 0000000..2549ac4
--- /dev/null
+++ b/recipes-mono/nuget/nuget_4.1.0.bb
@@ -0,0 +1,4 @@
+require nuget.inc
+
+SRC_URI[md5sum] = "ab763e8583a7970381aa42bf4b55d71a"
+SRC_URI[sha256sum] = "4c1de9b026e0c4ab087302ff75240885742c0faa62bd2554f913bbe1f6cb63a0"