aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-mono/mono/mono-6.12.0.122.inc5
-rw-r--r--recipes-mono/mono/mono-6.12.0.122/0001-patch-XplatUIX11-cursor.diff15
-rw-r--r--recipes-mono/mono/mono-6.12.0.122/shm_open-test-crosscompile.diff12
-rw-r--r--recipes-mono/mono/mono-native_6.12.0.122.bb20
-rw-r--r--recipes-mono/mono/mono_6.12.0.122.bb24
5 files changed, 76 insertions, 0 deletions
diff --git a/recipes-mono/mono/mono-6.12.0.122.inc b/recipes-mono/mono/mono-6.12.0.122.inc
new file mode 100644
index 0000000..89828b1
--- /dev/null
+++ b/recipes-mono/mono/mono-6.12.0.122.inc
@@ -0,0 +1,5 @@
+SRC_URI[sha256sum] = "29c277660fc5e7513107aee1cbf8c5057c9370a4cdfeda2fc781be6986d89d23"
+
+S = "${WORKDIR}/mono-${PV}"
+
+DEPENDS += " cmake-native"
diff --git a/recipes-mono/mono/mono-6.12.0.122/0001-patch-XplatUIX11-cursor.diff b/recipes-mono/mono/mono-6.12.0.122/0001-patch-XplatUIX11-cursor.diff
new file mode 100644
index 0000000..bcdad8f
--- /dev/null
+++ b/recipes-mono/mono/mono-6.12.0.122/0001-patch-XplatUIX11-cursor.diff
@@ -0,0 +1,15 @@
+diff -ur mono-6.8.0.96.org/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs mono-6.8.0.96/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs
+--- mono-6.8.0.96.org/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs 2020-01-15 07:46:01.000000000 +0000
++++ mono-6.8.0.96/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs 2020-02-08 21:22:11.059830600 +0000
+@@ -3091,6 +3091,11 @@
+ return IntPtr.Zero;
+ }
+
++ if(width == 0 || height == 0) {
++ width = bitmap.Width;
++ height = bitmap.Height;
++ }
++
+ // Win32 only allows creation cursors of a certain size
+ if ((bitmap.Width != width) || (bitmap.Width != height)) {
+ cursor_bitmap = new Bitmap(bitmap, new Size(width, height));
diff --git a/recipes-mono/mono/mono-6.12.0.122/shm_open-test-crosscompile.diff b/recipes-mono/mono/mono-6.12.0.122/shm_open-test-crosscompile.diff
new file mode 100644
index 0000000..62e49c6
--- /dev/null
+++ b/recipes-mono/mono/mono-6.12.0.122/shm_open-test-crosscompile.diff
@@ -0,0 +1,12 @@
+--- mono-6.8.0.96/configure.ac.orig 2019-03-15 10:45:13.000000000 -0400
++++ mono-6.8.0.96/configure.ac 2019-03-19 08:00:53.815148109 -0400
+@@ -3264,6 +3264,9 @@
+ AC_DEFINE(HAVE_SHM_OPEN_THAT_WORKS_WELL_ENOUGH_WITH_MMAP, 1, [shm_open that works well enough with mmap])
+ ], [
+ AC_MSG_RESULT(no)
++ ],[
++ AC_MSG_RESULT(yes)
++ AC_DEFINE(HAVE_SHM_OPEN_THAT_WORKS_WELL_ENOUGH_WITH_MMAP, 1, [shm_open that works well enough with mmap])
+ ])
+ fi
+
diff --git a/recipes-mono/mono/mono-native_6.12.0.122.bb b/recipes-mono/mono/mono-native_6.12.0.122.bb
new file mode 100644
index 0000000..0a90c22
--- /dev/null
+++ b/recipes-mono/mono/mono-native_6.12.0.122.bb
@@ -0,0 +1,20 @@
+require mono-6.xx.inc
+require mono-mit-bsd-6xx.inc
+require mono-native-6.xx-base.inc
+require mono-${PV}.inc
+
+SRC_URI = "http://download.mono-project.com/sources/mono/mono-${PV}.tar.xz \
+ file://0001-patch-XplatUIX11-cursor.diff \
+ file://shm_open-test-crosscompile.diff \
+"
+
+addtask fixup_config after do_patch before do_configure
+
+do_fixup_config() {
+ sed 's|$mono_libdir/libMonoPosixHelper@libsuffix@|libMonoPosixHelper.so|g' -i ${S}/data/config.in
+ sed 's|@X11@|libX11.so.6|g' -i ${S}/data/config.in
+ sed 's|@libgdiplus_install_loc@|libgdiplus.so.0|g' -i ${S}/data/config.in
+}
+
+
+
diff --git a/recipes-mono/mono/mono_6.12.0.122.bb b/recipes-mono/mono/mono_6.12.0.122.bb
new file mode 100644
index 0000000..931fd30
--- /dev/null
+++ b/recipes-mono/mono/mono_6.12.0.122.bb
@@ -0,0 +1,24 @@
+require mono-6.xx.inc
+require mono-mit-bsd-6xx.inc
+require ${PN}-base.inc
+require mono-${PV}.inc
+
+RDEPENDS_${PN}-dev =+ " zlib "
+
+SRC_URI = "http://download.mono-project.com/sources/mono/mono-${PV}.tar.xz \
+ file://shm_open-test-crosscompile.diff \
+"
+
+
+addtask fixup_config after do_patch before do_configure
+
+do_fixup_config() {
+ sed 's|$mono_libdir/libMonoPosixHelper@libsuffix@|libMonoPosixHelper.so|g' -i ${S}/data/config.in
+ sed 's|@X11@|libX11.so.6|g' -i ${S}/data/config.in
+ sed 's|@libgdiplus_install_loc@|libgdiplus.so.0|g' -i ${S}/data/config.in
+}
+
+PACKAGES += "${PN}-profiler "
+FILES_${PN}-profiler += " ${datadir}/mono-2.0/mono/profiler/*"
+
+INSANE_SKIP_${PN}-libs += "dev-so"